Every CVE Search/ Get API key

CVE-2011-2687

Drupal Access Control Bypass

7.5 HighFix available

Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.

Exploit likelihood

3.06%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.

Record
CVE-2011-2687
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.

Record
CVE-2011-2687
Updated
2026-11-02
EUVDEUVD-2022-3306 No score

Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.

Record
EUVD-2022-3306
Updated
2026-11-03
GitHub AdvisoriesGHSA-96vx-qf28-6f8m No score

Drupal Access Control Bypass

Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.

Record
GHSA-96vx-qf28-6f8m
Weakness
CWE-284
Updated
2026-11-02
OSVGHSA-96vx-qf28-6f8m No score

Drupal Access Control Bypass

Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.

Record
GHSA-96vx-qf28-6f8m
Weakness
CWE-284
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/core
Packagist
7.0 up to 7.3
7.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2687 is a high vulnerability (CVSS 7.5) in Drupal, published July 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.06%, the 87th percentile. Fixed in drupal/core 7.3.

References

Show 7 moreShow less
MoveEnter Open