Every CVE Search/ Get API key

CVE-2014-3623

Improper Authentication in Apache WSS4J

5.0 MediumFix available

Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

Exploit likelihood

9.22%Up 2.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

Record
CVE-2014-3623
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-287
Updated
2026-11-02
CVE List No score

Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

Record
CVE-2014-3623
Updated
2026-11-02
EUVDEUVD-2022-3343 No score

Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

Record
EUVD-2022-3343
Updated
2026-11-03
GitHub AdvisoriesGHSA-99v3-9x35-c5vf No score

Improper Authentication in Apache WSS4J

Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

Record
GHSA-99v3-9x35-c5vf
Weakness
CWE-287
Updated
2026-11-02
OSVRHSA-2014:2019 4.8

Red Hat Security Advisory: Red Hat JBoss Enterprise Application Platform 6.3.2 security update

Record
RHSA-2014:2019
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-99v3-9x35-c5vf No score

Improper Authentication in Apache WSS4J

Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

Record
GHSA-99v3-9x35-c5vf
Weakness
CWE-287
Updated
2026-11-02
OSVMGASA-2014-0552 No score

Updated wss4j packages fix CVE-2014-3623

Updated wss4j packages fixes security vulnerability:

Apache WSS4J before 1.6.17, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors (CVE-2014-3623).

Record
MGASA-2014-0552
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.ws.security:wss4j
Maven
before 1.6.17
1.6.17
org.apache.wss4j:wss4j-ws-security-dom
Maven
2.0.0 up to 2.0.2
2.0.2
org.apache.ws.security:wss4j
Maven
before 1.6.17, plus listed versions
1.5.101.5.111.5.121.5.21.5.3
Show 23 moreShow less
1.5.41.5.51.5.61.5.71.5.81.5.91.6.01.6.11.6.101.6.111.6.121.6.131.6.141.6.151.6.161.6.21.6.31.6.41.6.51.6.61.6.71.6.81.6.9
1.6.17
org.apache.wss4j:wss4j-ws-security-dom
Maven
2.0.0 up to 2.0.2, plus listed versions
2.0.1
2.0.2
wss4j
Mageia:4
before 1.6.17-1.mga4
1.6.17-1.mga4
apache-cxf
Red Hat:jboss_enterprise_application_platform:6::el5
From an advisory covering 3 CVEs
before 0:2.7.12-1.SP1_redhat_5.1.ep6.el5
0:2.7.12-1.SP1_redhat_5.1.ep6.el5
wss4j
Red Hat:jboss_enterprise_application_platform:6::el5
From an advisory covering 3 CVEs
before 0:1.6.16-2.redhat_3.1.ep6.el5
0:1.6.16-2.redhat_3.1.ep6.el5
apache-cxf
Red Hat:jboss_enterprise_application_platform:6::el6
From an advisory covering 3 CVEs
before 0:2.7.12-1.SP1_redhat_5.1.ep6.el6
0:2.7.12-1.SP1_redhat_5.1.ep6.el6
wss4j
Red Hat:jboss_enterprise_application_platform:6::el6
From an advisory covering 3 CVEs
before 0:1.6.16-2.redhat_3.1.ep6.el6
0:1.6.16-2.redhat_3.1.ep6.el6
apache-cxf
Red Hat:jboss_enterprise_application_platform:6::el7
From an advisory covering 3 CVEs
before 0:2.7.12-1.SP1_redhat_5.1.ep6.el7
0:2.7.12-1.SP1_redhat_5.1.ep6.el7
wss4j
Red Hat:jboss_enterprise_application_platform:6::el7
From an advisory covering 3 CVEs
before 0:1.6.16-2.redhat_3.1.ep6.el7
0:1.6.16-2.redhat_3.1.ep6.el7

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3623 is a medium vulnerability (CVSS 5.0) in Apache Cxf, published October 30, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.22%, the 95th percentile. Fixed in org.apache.ws.security:wss4j 1.6.17.

References

Show 34 moreShow less
MoveEnter Open