Every CVE Search/ Get API key

CVE-2022-29021

A buffer overflow in the razerkbd driver of OpenRazer v3.3.0 and below allows attackers to cause...

9.8 CriticalFix available

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.29%Up 1.4 points since May 21, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Record
CVE-2022-29021
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Record
CVE-2022-29021
Updated
2026-11-02
EUVDEUVD-2022-33451 No score

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Record
EUVD-2022-33451
Updated
2026-11-02
GitHub AdvisoriesGHSA-xm8g-mhgj-5vhv 7.5

A buffer overflow in the razerkbd driver of OpenRazer v3.3.0 and below allows attackers to cause...

A buffer overflow in the razerkbd driver of OpenRazer v3.3.0 and below allows attackers to cause a Denial of Service (DoS) via a crafted buffer sent to the matrix_custom_frame device.

Record
GHSA-xm8g-mhgj-5vhv
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
OSVALPINE-CVE-2022-29021 9.8

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Record
ALPINE-CVE-2022-29021
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-29021 9.8

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Record
UBUNTU-CVE-2022-29021
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Record
CVE-2022-29021
Updated
2026-11-02
OSVDEBIAN-CVE-2022-29021 No score

A buffer overflow vulnerability exists in the razerkbd driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.

Record
DEBIAN-CVE-2022-29021
Updated
2026-11-03

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openrazer
Alpine:v3.18
before 3.4.0-r0
3.4.0-r0
openrazer
Alpine:v3.19
before 3.4.0-r0
3.4.0-r0
openrazer
Alpine:v3.20
before 3.4.0-r0
3.4.0-r0
openrazer
Alpine:v3.21
before 3.4.0-r0
3.4.0-r0
openrazer
Alpine:v3.22
before 3.4.0-r0
3.4.0-r0
openrazer
Alpine:v3.23
before 3.4.0-r0
3.4.0-r0
openrazer
Alpine:v3.24
before 3.4.0-r0
3.4.0-r0
openrazer
Debian:12
before 3.3.0+dfsg-1
3.3.0+dfsg-1
openrazer
Debian:13
before 3.3.0+dfsg-1
3.3.0+dfsg-1
openrazer
Debian:14
before 3.3.0+dfsg-1
3.3.0+dfsg-1
openrazer
Debian:11
before 2.9.0+dfsg-1+deb11u1, plus listed versions
2.9.0+dfsg-1
2.9.0+dfsg-1+deb11u1
openrazer
Ubuntu:20.04:LTS
All versions, plus listed versions
2.5.0+dfsg-1ubuntu2
None known
openrazer
Ubuntu:22.04:LTS
All versions, plus listed versions
2.9.0+dfsg-1ubuntu13.2.0+dfsg-3
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-29021 is a critical vulnerability (CVSS 9.8) in Openrazer Project Openrazer, published May 20, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.29%, the 83rd percentile. Fixed in openrazer 3.4.0-r0.

References

Show 5 moreShow less
MoveEnter Open