CVE-2020-2090
CSRF vulnerability in Jenkins Amazon EC2 Plugin
A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.47 and earlier allows attackers to connect to an attacker-specified URL within the AWS region using attacker-specified credentials IDs obtained through another method.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.47 and earlier allows attackers to connect to an attacker-specified URL within the AWS region using attacker-specified credentials IDs obtained through another method.
- Record
CVE-2020-2090- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.47 and earlier allows attackers to connect to an attacker-specified URL within the AWS region using attacker-specified credentials IDs obtained through another method.
- Record
CVE-2020-2090- Updated
- 2026-11-02
EUVDEUVD-2022-3396 No score
A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.47 and earlier allows attackers to connect to an attacker-specified URL within the AWS region using attacker-specified credentials IDs obtained through another method.
- Record
EUVD-2022-3396- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9hvf-pfq3-7pp6
3.1
CSRF vulnerability in Jenkins Amazon EC2 Plugin
Amazon EC2 Plugin 1.47 and earlier does not perform permission checks in methods performing form validation. This allows users with Overall/Read access to Jenkins to connect to an attacker-specified URL within the AWS region using attacker-specified credentials IDs obtained through another method.
This vulnerability might also allow attackers to capture credentials stored in Jenkins. We have not been able to confirm that this is possible.
Additionally, these form validation methods do not require POST requests, resulting in a CSRF vulnerability.
Amazon EC2 Plugin 1.48 requires POST requests and Overall/Administer permission for the affected form validation methods.
- Record
GHSA-9hvf-pfq3-7pp6- CVSS 3.1
- 3.1 Low
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVGHSA-9hvf-pfq3-7pp6
3.1
CSRF vulnerability in Jenkins Amazon EC2 Plugin
Amazon EC2 Plugin 1.47 and earlier does not perform permission checks in methods performing form validation. This allows users with Overall/Read access to Jenkins to connect to an attacker-specified URL within the AWS region using attacker-specified credentials IDs obtained through another method.
This vulnerability might also allow attackers to capture credentials stored in Jenkins. We have not been able to confirm that this is possible.
Additionally, these form validation methods do not require POST requests, resulting in a CSRF vulnerability.
Amazon EC2 Plugin 1.48 requires POST requests and Overall/Administer permission for the affected form validation methods.
- Record
GHSA-9hvf-pfq3-7pp6- CVSS 3.1
- 3.1 Low
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.plugins:ec2Maven |
before 1.48 | 1.48 |
org.jenkins-ci.plugins:ec2Maven |
before 1.48, plus listed versions 1.111.121.131.141.15 Show 41 moreShow less1.161.171.181.191.201.211.221.231.241.251.261.271.281.291.301.311.321.331.341.351.361.371.381.391.401.40.11.411.41.11.421.42.11.42.21.431.441.44.11.451.461.46.11.46.21.46.31.46.41.47 |
1.48 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-2090 is a high vulnerability (CVSS 8.8) in Jenkins Amazon Ec2, published January 15, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in org.jenkins-ci.plugins:ec2 1.48.