CVE-2022-1810
Authorization Bypass Through User-Controlled Key in publify/publify
Authorization Bypass Through User-Controlled Key in GitHub repository publify/publify prior to 9.2.9.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.9
Authorization Bypass Through User-Controlled Key in publify/publify
Authorization Bypass Through User-Controlled Key in GitHub repository publify/publify prior to 9.2.9.
- Record
CVE-2022-1810- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:H - Weakness
- CWE-639
- Updated
- 2026-11-02
EUVDEUVD-2022-3472
9.9
Authorization Bypass Through User-Controlled Key in GitHub repository publify/publify prior to 9.2.9.
- Record
EUVD-2022-3472- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c273-c6vg-4pv5
4.3
Publify has Improper Access Controls
A low-privileged user can modify and delete admin articles by changing the value of the article[id] parameter prior to 9.2.9.
- Record
GHSA-c273-c6vg-4pv5- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-284, CWE-639, CWE-732
- Updated
- 2026-11-02
NVD
4.3
Authorization Bypass Through User-Controlled Key in GitHub repository publify/publify prior to 9.2.9.
- Record
CVE-2022-1810- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:H - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-639
- Updated
- 2026-11-02
OSV
9.9
Authorization Bypass Through User-Controlled Key in publify/publify
Authorization Bypass Through User-Controlled Key in GitHub repository publify/publify prior to 9.2.9.
- Record
CVE-2022-1810- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:H - Weakness
- CWE-639
- Updated
- 2026-11-02
OSVGHSA-c273-c6vg-4pv5
4.3
Publify has Improper Access Controls
A low-privileged user can modify and delete admin articles by changing the value of the article[id] parameter prior to 9.2.9.
- Record
GHSA-c273-c6vg-4pv5- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-284, CWE-639, CWE-732
- Updated
- 2026-11-02
OSVBIT-publify-2022-1810 No score
Authorization Bypass Through User-Controlled Key in GitHub repository publify/publify prior to 9.2.9.
- Record
BIT-publify-2022-1810- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.9 | 9.2.9 |
publifyBitnami |
before 9.2.9 | 9.2.9 |
publify_coreRubyGems |
before 9.2.9, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 13 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.79.2.8 |
9.2.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-1810 is a critical vulnerability (CVSS 9.9) in Publify Publify/publify, published May 23, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 58th percentile. Fixed in publify_core 9.2.9.
References
huntr.dev/bounties/9b2d7579-032e-42da-b736-4b10a868eacb
github.com/publify/publify/commit/c0aba87844d1e47da50c0d99a3465164a4d244ce
nvd.nist.gov/vuln/detail/CVE-2022-1810
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2022-1810.yml
github.com/advisories/GHSA-c273-c6vg-4pv5
github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1810.json
github.com/publify/publify