CVE-2016-3109
Shopware RCE Vulnerability
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
- Record
CVE-2016-3109- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
- Record
CVE-2016-3109- Updated
- 2026-11-02
EUVDEUVD-2022-3584 No score
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
- Record
EUVD-2022-3584- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cj2f-96jq-phpp
9.8
Shopware RCE Vulnerability
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
- Record
GHSA-cj2f-96jq-phpp- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-cj2f-96jq-phpp
9.8
Shopware RCE Vulnerability
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
- Record
GHSA-cj2f-96jq-phpp- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
shopware/shopwarePackagist |
before 4.3.7 | 4.3.7 |
shopware/shopwarePackagist |
5.0.0 up to 5.1.5 | 5.1.5 |
shopware/shopwarePackagist |
before 4.3.7, plus listed versions 1.0.21.0.84.2.04.2.0-rc.14.2.1 Show 10 moreShow less4.2.1.14.2.24.2.34.3.04.3.14.3.24.3.34.3.44.3.54.3.6 |
4.3.7 |
shopware/shopwarePackagist |
5.0.0 up to 5.1.5, plus listed versions v5.0.0v5.0.1v5.0.2v5.0.2-RC1v5.0.3 Show 13 moreShow lessv5.0.3-RC1v5.0.4v5.0.4-RC1v5.1.0v5.1.0-RC2v5.1.0-RC3v5.1.1v5.1.2v5.1.2-RC1v5.1.2-RC2v5.1.3v5.1.3-RC1v5.1.4 |
5.1.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-3109 is a critical vulnerability (CVSS 9.8) in Shopware, published April 21, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 28.1%, the 98th percentile. Fixed in shopware/shopware 4.3.7.
References
github.com/shopware/shopware/commit/d73e9031a5b2ab6e918eb86d1e2b2e873cd3558d
packetstormsecurity.com/files/136781/Shopware-Remote-Code-Execution.html
securityfocus.com/bid/97979
securityfocus.com/archive/1/538173/100/0/threaded
nvd.nist.gov/vuln/detail/CVE-2016-3109
web.archive.org/web/20200814090044/http://www.securityfocus.com/archive/1/538173/100/0/threaded