Every CVE Search/ Get API key

CVE-2018-14057

Pimcore CSRF Vulnerability

8.8 HighPublic exploitFix available

Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.29%Down 2.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.

Record
CVE-2018-14057
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.

Record
CVE-2018-14057
Updated
2026-11-02
EUVDEUVD-2022-3975 No score

Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.

Record
EUVD-2022-3975
Updated
2026-11-03
GitHub AdvisoriesGHSA-gmff-vcv6-mmfr 8.8

Pimcore CSRF Vulnerability

Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.

Record
GHSA-gmff-vcv6-mmfr
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSV 8.8

Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.

Record
CVE-2018-14057
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-gmff-vcv6-mmfr 8.8

Pimcore CSRF Vulnerability

Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.

Record
GHSA-gmff-vcv6-mmfr
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pimcore/pimcore
Packagist
before 5.3.0
5.3.0
pimcore/pimcore
Packagist
before 5.3.0, plus listed versions
2.2.02.2.12.2.22.3.03.0.0
Show 43 moreShow less
3.0.13.0.23.0.33.0.43.0.53.0.63.1.03.1.14.0.04.0.14.1.04.1.14.1.24.1.34.2.04.3.04.3.14.4.04.4.14.4.24.4.34.5.04.6.04.6.14.6.24.6.34.6.44.6.5v5.0.0v5.0.0-RCv5.0.1v5.0.2v5.0.3v5.0.4v5.1.0v5.1.0-alphav5.1.1v5.1.2v5.1.3v5.2.0v5.2.1v5.2.2v5.2.3
5.3.0

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-14057 is a high vulnerability (CVSS 8.8) in Pimcore, published August 17, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.29%, the 88th percentile. Fixed in pimcore/pimcore 5.3.0.

References

MoveEnter Open