Every CVE Search/ Get API key

CVE-2018-1000422

Jenkins Crowd 2 Integration Plugin server-side request forgery vulnerability

6.5 MediumFix available

An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.77%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

Record
CVE-2018-1000422
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

Record
CVE-2018-1000422
Updated
2026-11-02
EUVDEUVD-2022-4002 No score

An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

Record
EUVD-2022-4002
Updated
2026-11-03
GitHub AdvisoriesGHSA-grmg-5q49-mqmf 6.5

Jenkins Crowd 2 Integration Plugin server-side request forgery vulnerability

An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

Record
GHSA-grmg-5q49-mqmf
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-918
Updated
2026-11-02
OSVGHSA-grmg-5q49-mqmf 6.5

Jenkins Crowd 2 Integration Plugin server-side request forgery vulnerability

An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

Record
GHSA-grmg-5q49-mqmf
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-918
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.jenkins-ci.plugins:crowd2
Maven
through 2.0.0
2.0.1
org.jenkins-ci.plugins:crowd2
Maven
before 2.0.1, plus listed versions
1.01.11.21.31.4
Show 9 moreShow less
1.51.61.71.82.0.02.0.0-beta12.0.0-beta22.0.0-beta32.0.0-beta4
2.0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1000422 is a medium vulnerability (CVSS 6.5) in Atlassian Crowd2, published January 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.77%, the 55th percentile. Fixed in org.jenkins-ci.plugins:crowd2 2.0.1.

References

MoveEnter Open