Every CVE Search/ Get API key

CVE-2015-1786

Zend Framework CSRF Vulnerability

8.8 HighFix available

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.66%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Record
CVE-2015-1786
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Record
CVE-2015-1786
Updated
2026-11-02
EUVDEUVD-2022-4027 No score

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Record
EUVD-2022-4027
Updated
2026-11-03
GitHub AdvisoriesGHSA-gwwq-54qp-9pgp 8.8

Zend Framework CSRF Vulnerability

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Record
GHSA-gwwq-54qp-9pgp
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-gwwq-54qp-9pgp 8.8

Zend Framework CSRF Vulnerability

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Record
GHSA-gwwq-54qp-9pgp
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zendframework/zendframework
Packagist
2.3.0 up to 2.3.6
2.3.6
zendframework/zendframework
Packagist
2.3.0 up to 2.3.6, plus listed versions
2.3.12.3.22.3.32.3.42.3.5
2.3.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1786 is a high vulnerability (CVSS 8.8) in Zend Framework, published June 8, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.66%, the 51st percentile. Fixed in zendframework/zendframework 2.3.6.

References

MoveEnter Open