Every CVE Search/ Get API key

CVE-2019-16370

Use of a weak cryptographic algorithm in Gradle

5.9 MediumFix available

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.89%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.9

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
CVE-2019-16370
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-327
Updated
2026-11-02
CVE List No score

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
CVE-2019-16370
Updated
2026-11-02
EUVDEUVD-2022-4164 No score

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
EUVD-2022-4164
Updated
2026-11-03
GitHub AdvisoriesGHSA-hhr2-f668-ff2w No score

Use of a weak cryptographic algorithm in Gradle

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
GHSA-hhr2-f668-ff2w
Weakness
CWE-327
Updated
2026-11-02
OSV 5.9

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
CVE-2019-16370
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2019-16370 5.9

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
DEBIAN-CVE-2019-16370
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 5 moreShow less
OSVOESA-2021-1309 5.9

gradle security update

Gradle is build automation evolved. Gradle can automate the building, testing, publishing, deployment and more of software packages or other types of projects such as generated static websites, generated documentation or indeed anything else. Gradle combines the power and flexibility of Ant with the dependency management and conventions of Maven into a more effective way to build. Powered by a Groovy DSL and packed with innovation, Gradle provides a declarative way to describe all kinds of builds through sensible defaults. Gradle is quickly becoming the build system of choice for many open source projects, leading edge enterprises and legacy automation challenges.

Security Fix(es):

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.(CVE-2019-16370)

Record
OESA-2021-1309
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2019-16370 5.9

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
UBUNTU-CVE-2019-16370
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-hhr2-f668-ff2w No score

Use of a weak cryptographic algorithm in Gradle

The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

Record
GHSA-hhr2-f668-ff2w
Weakness
CWE-327
Updated
2026-11-02
OSVopenSUSE-SU-2024:10817-1 No score

gradle-4.4.1-7.2 on GA media

These are all security issues fixed in the gradle-4.4.1-7.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10817-1
Updated
2026-11-02
OSVUSN-4858-1 No score

gradle vulnerabilities

It was discovered that Gradle used an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins were used. A remote unauthenticated attacker could possibly use this issue to perform a machine-in-the-middle attack. (CVE-2019-11065)

It was discovered that the PGP signing plugin in Gradle relied on the insecure SHA-1 algorithm. An attacker could possibly use this issue to conduct spoofing attacks. (CVE-2019-16370)

Record
USN-4858-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.gradle:gradle-core
Maven
before 6.0
6.0
gradle
Debian:12
before 4.4.1-18
4.4.1-18
gradle
Debian:13
before 4.4.1-18
4.4.1-18
gradle
Debian:14
before 4.4.1-18
4.4.1-18
gradle
openEuler:20.03-LTS-SP1
before 4.4.1-2.oe1
4.4.1-2.oe1
gradle
openEuler:20.03-LTS-SP2
before 4.4.1-2.oe1
4.4.1-2.oe1
gradle
Ubuntu:16.04:LTS
All versions, plus listed versions
2.5-32.7-12.7-22.7-32.10-1
None known
gradle
Ubuntu:Pro:18.04:LTS
before 4.4.1-5ubuntu2~18.04+esm1, plus listed versions
3.2.1-3build23.2.1-43.2.1-53.4.1-43.4.1-63.4.1-7ubuntu14.4.1-5ubuntu2~18.04
4.4.1-5ubuntu2~18.04+esm1
gradle
Ubuntu:20.04:LTS
All versions, plus listed versions
4.4.1-84.4.1-94.4.1-10
None known
gradle
Ubuntu:22.04:LTS
All versions, plus listed versions
4.4.1-13
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
gradle
Ubuntu:24.04:LTS
All versions, plus listed versions
4.4.1-184.4.1-20
None known
gradle
Ubuntu:25.10
All versions, plus listed versions
4.4.1-22
None known
gradle
Ubuntu:26.10
All versions, plus listed versions
4.4.1-22ubuntu14.4.1-23
None known
gradle
Ubuntu:26.04:LTS
All versions, plus listed versions
4.4.1-224.4.1-22build14.4.1-22ubuntu1
None known
gradle
openSUSE:Tumbleweed
before 4.4.1-7.2
4.4.1-7.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-16370 is a medium vulnerability (CVSS 5.9) in Gradle, published September 16, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.89%, the 59th percentile. Fixed in org.gradle:gradle-core 6.0.

References

Show 5 moreShow less
MoveEnter Open