Every CVE Search/ Get API key

CVE-2022-39346

Missing length validation of user displayname in nextcloud server

3.5 Low

Nextcloud server is an open source personal cloud server. Affected versions of nextcloud server did not properly limit user display names which could allow a malicious users to overload the backing database and cause a denial of service. It is recommended that the Nextcloud Server is upgraded to 22.2.10, 23.0.7 or 24.0.3. There are no known workarounds for this issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

1.10%Up 0.2 points since Nov 26, 2022
90%50%10%1%

What each source reports

CVE List Score used 3.5

Missing length validation of user displayname in nextcloud server

Nextcloud server is an open source personal cloud server. Affected versions of nextcloud server did not properly limit user display names which could allow a malicious users to overload the backing database and cause a denial of service. It is recommended that the Nextcloud Server is upgraded to 22.2.10, 23.0.7 or 24.0.3. There are no known workarounds for this issue.

Record
CVE-2022-39346
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
Weakness
CWE-400, CWE-20
Updated
2026-11-02
EUVDEUVD-2022-41818 3.5

Nextcloud server is an open source personal cloud server. Affected versions of nextcloud server did not properly limit user display names which could allow a malicious users to overload the backing database and cause a denial of service. It is recommended that the Nextcloud Server is upgraded to 22.2.10, 23.0.7 or 24.0.3. There are no known workarounds for this issue.

Record
EUVD-2022-41818
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
Updated
2026-11-02
NVD 3.5

Nextcloud server is an open source personal cloud server. Affected versions of nextcloud server did not properly limit user display names which could allow a malicious users to overload the backing database and cause a denial of service. It is recommended that the Nextcloud Server is upgraded to 22.2.10, 23.0.7 or 24.0.3. There are no known workarounds for this issue.

Record
CVE-2022-39346
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20, CWE-400
Updated
2026-11-02
OSV 3.5

Missing length validation of user displayname in nextcloud server

Nextcloud server is an open source personal cloud server. Affected versions of nextcloud server did not properly limit user display names which could allow a malicious users to overload the backing database and cause a denial of service. It is recommended that the Nextcloud Server is upgraded to 22.2.10, 23.0.7 or 24.0.3. There are no known workarounds for this issue.

Record
CVE-2022-39346
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
Weakness
CWE-20, CWE-400
Updated
2026-11-02
OSVopenSUSE-SU-2023:0083-1 No score

Security update for nextcloud

This update for nextcloud fixes the following issues:

  • Update to 23.0.12 See: https://nextcloud.com/changelog/#latest23

  • This also fix security issues:

    • CVE-2022-35931: Password Policy app could generate passwords that would be block (boo#1203190)
    • CVE-2022-39346: Missing length validation of user displayname allows to generate an SQL error (boo#1205802)
    • CVE-2023-25579: Potential directory traversal in OC\Files\Node\Folder::getFullPath (boo#1208591)
Record
openSUSE-SU-2023:0083-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nextcloud
SUSE:Package Hub 15 SP4
From an advisory covering 3 CVEs
before 23.0.12-bp154.2.3.1
23.0.12-bp154.2.3.1
nextcloud
openSUSE:Leap 15.4
From an advisory covering 3 CVEs
before 23.0.12-bp154.2.3.1
23.0.12-bp154.2.3.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-39346 is a low vulnerability (CVSS 3.5) in Nextcloud Server, published November 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. No source names a fixed version.

References

Show 9 moreShow less
MoveEnter Open