Every CVE Search/ Get API key

CVE-2013-6389

Drupal has open redirect vulnerability in the Overlay module

5.8 MediumFix available

Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.24 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Exploit likelihood

1.21%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.24 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Record
CVE-2013-6389
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.24 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Record
CVE-2013-6389
Updated
2026-11-02
EUVDEUVD-2022-4240 No score

Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.24 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Record
EUVD-2022-4240
Updated
2026-11-03
GitHub AdvisoriesGHSA-hxg2-5c8p-ppwm 8.7

Drupal has open redirect vulnerability in the Overlay module

Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.24 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Record
GHSA-hxg2-5c8p-ppwm
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20, CWE-601
Updated
2026-11-02
OSVGHSA-hxg2-5c8p-ppwm 8.7

Drupal has open redirect vulnerability in the Overlay module

Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.24 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Record
GHSA-hxg2-5c8p-ppwm
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20, CWE-601
Updated
2026-11-02
OSVMGASA-2013-0359 No score

Updated drupal package fixes security vulnerabilities

Drupal's form API has built-in cross-site request forgery (CSRF) validation, and also allows any module to perform its own validation on the form. In certain common cases, form validation functions may execute unsafe operations (CVE-2013-6385).

Drupal core directly used the mt_rand() pseudorandom number generator for generating security related strings used in several core modules. It was found that brute force tools could determine the seeds making these strings predictable under certain circumstances (CVE-2013-6386).

Image field descriptions are not properly sanitized before they are printed to HTML, thereby exposing a cross-site scripting vulnerability (CVE-2013-6387).

A cross-site scripting vulnerability was found in the Color module. A malicious attacker could trick an authenticated administrative user into visiting a page containing specific JavaScript that could lead to a reflected cross-site scripting attack via JavaScript execution in CSS (CVE-2013-6388).

The Overlay module displays administrative pages as a layer over the current page (using JavaScript), rather than replacing the page in the browser window. The Overlay module did not sufficiently validate URLs prior to displaying their contents, leading to an open redirect vulnerability (CVE-2013-6389).

Record
MGASA-2013-0359
Updated
2026-11-02
OSVUBUNTU-CVE-2013-6389 No score

Open redirect vulnerability in the Overlay module in Drupal 7.x before 7.24 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Record
UBUNTU-CVE-2013-6389
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/drupal
Packagist
7.0 up to 7.24
7.24
drupal7
Debian:7
From an advisory covering 5 CVEs
before 7.14-2+deb7u1, plus listed versions
7.14-27.14-2+deb7u1~bpo60+1
7.14-2+deb7u1
drupal
Mageia:3
From an advisory covering 5 CVEs
before 7.24-1.1.mga3
7.24-1.1.mga3

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-6389 is a medium vulnerability (CVSS 5.8) in Drupal, published November 26, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.21%, the 68th percentile. Fixed in drupal/drupal 7.24.

References

Show 5 moreShow less
MoveEnter Open