CVE-2022-3276
Puppetlabs-mysql Command Injection
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.4
Puppetlabs-mysql Command Injection
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
CVE-2022-3276- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2022-42673
8.4
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
EUVD-2022-42673- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6wx8-c453-jp55
8.8
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious...
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
GHSA-6wx8-c453-jp55- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77, CWE-78
- Updated
- 2026-11-02
NVD
8.4
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
CVE-2022-3276- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
8.8
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
CVE-2022-3276- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVRHSA-2022:7238
8.4
Red Hat Security Advisory: Red Hat OpenStack Platform (puppet-mysql) security update
- Record
RHSA-2022:7238- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-3276
8.4
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
UBUNTU-CVE-2022-3276- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-3276 No score
Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
DEBIAN-CVE-2022-3276- Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
puppet-module-puppetlabs-mysqlDebian:12 |
All versions, plus listed versions 15.0.0-115.0.0-215.0.0-315.0.0-48.1.0-7 |
None known |
puppet-module-puppetlabs-mysqlDebian:13 |
before 15.0.0-1 | 15.0.0-1 |
puppet-module-puppetlabs-mysqlDebian:14 |
before 15.0.0-1 | 15.0.0-1 |
puppet-mysqlRed Hat:openstack:13::el7 |
before 0:5.2.2-0.20180216012143.a5497b2.el7ost | 0:5.2.2-0.20180216012143.a5497b2.el7ost |
puppet-mysqlRed Hat:openstack:16.1::el8 |
before 0:10.4.1-2.20221019195006.95f9b98.el8ost | 0:10.4.1-2.20221019195006.95f9b98.el8ost |
puppet-mysqlRed Hat:openstack:16.2::el8 |
before 0:10.4.1-2.20221019195006.95f9b98.el8ost | 0:10.4.1-2.20221019195006.95f9b98.el8ost |
puppet-mysqlRed Hat:openstack:17.0::el9 |
before 0:10.6.1-0.20220614215045.937d044.el9ost | 0:10.6.1-0.20220614215045.937d044.el9ost |
puppet-module-puppetlabs-mysqlUbuntu:16.04:LTS |
All versions, plus listed versions 2.3.1-13.6.1-1 |
None known |
puppet-module-puppetlabs-mysqlUbuntu:18.04:LTS |
All versions, plus listed versions 3.10.0-1 |
None known |
puppet-module-puppetlabs-mysqlUbuntu:20.04:LTS |
All versions, plus listed versions 5.3.0-1ubuntu18.1.0-2ubuntu1 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
puppet-module-puppetlabs-mysqlUbuntu:22.04:LTS |
All versions, plus listed versions 8.1.0-5ubuntu1 |
None known |
puppet-module-puppetlabs-mysqlUbuntu:24.04:LTS |
All versions, plus listed versions 8.1.0-7ubuntu1 |
None known |
puppet-module-puppetlabs-mysqlUbuntu:25.10 |
All versions, plus listed versions 8.1.0-7ubuntu1 |
None known |
puppet-module-puppetlabs-mysqlUbuntu:26.10 |
All versions, plus listed versions 8.1.0-7ubuntu2 |
None known |
puppet-module-puppetlabs-mysqlUbuntu:26.04:LTS |
All versions, plus listed versions 8.1.0-7ubuntu18.1.0-7ubuntu2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-3276 is a high vulnerability (CVSS 8.4) in Puppet Puppetlabs-mysql, published October 7, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in puppet-module-puppetlabs-mysql 15.0.0-1.
References
puppet.com/security/cve/CVE-2022-3276
nvd.nist.gov/vuln/detail/CVE-2022-3276
github.com/advisories/GHSA-6wx8-c453-jp55
security-tracker.debian.org/tracker/CVE-2022-3276
access.redhat.com/errata/RHSA-2022:7238
access.redhat.com/security/updates/classification
Show 7 moreShow less
bugzilla.redhat.com/show_bug.cgi?id=2132541
security.access.redhat.com/data/csaf/v2/advisories/2022/rhsa-2022_7238.json
access.redhat.com/security/cve/CVE-2022-3276
cve.org/CVERecord?id=CVE-2022-3276
ubuntu.com/security/CVE-2022-3276
github.com/puppetlabs/puppetlabs-mysql/compare/v12.0.3...v13.0.0
github.com/puppetlabs/puppetlabs-mysql/pull/1484