CVE-2016-7954
Bundler allows attacker to inject arbitrary code via secondary Gem source
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
- Record
CVE-2016-7954- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
- Record
CVE-2016-7954- Updated
- 2026-11-02
EUVDEUVD-2022-4435 No score
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
- Record
EUVD-2022-4435- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jvgm-pfqv-887x
9.8
Bundler allows attacker to inject arbitrary code via secondary Gem source
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
- Record
GHSA-jvgm-pfqv-887x- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
9.8
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
- Record
CVE-2016-7954- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-jvgm-pfqv-887x
9.8
Bundler allows attacker to inject arbitrary code via secondary Gem source
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
- Record
GHSA-jvgm-pfqv-887x- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-7954
9.8
Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
- Record
UBUNTU-CVE-2016-7954- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bundlerRubyGems |
1.0.0 up to 2.0.0 | 2.0.0 |
bundlerRubyGems |
1.0.0 up to 2.0.0, plus listed versions 1.0.101.0.111.0.121.0.131.0.14 Show 45 moreShow less1.0.151.0.171.0.181.0.19.rc1.0.21.0.201.0.20.rc1.0.211.0.21.rc1.0.221.0.31.0.51.0.71.0.91.1.01.1.11.1.21.1.31.1.41.1.51.1.pre1.1.pre.11.1.pre.101.1.pre.21.1.pre.31.1.pre.41.1.pre.51.1.pre.71.1.pre.81.1.pre.91.1.rc1.1.rc.21.1.rc.31.1.rc.51.1.rc.61.1.rc.71.1.rc.81.10.01.10.0.pre1.10.0.pre.11.10.0.pre.21.10.0.rc1.10.11.10.21.10.3 |
2.0.0 |
bundlerUbuntu:16.04:LTS |
All versions, plus listed versions 1.10.6-11.10.6-21.11.2-1 |
None known |
bundlerUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.15.1-11.16.1-11.16.1-1ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-7954 is a critical vulnerability (CVSS 9.8) in Bundler, published December 22, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.82%, the 95th percentile. Fixed in bundler 2.0.0.
References
securityfocus.com/bid/93423
github.com/bundler/bundler/issues/5062
collectiveidea.com/blog/archives/2016/10/06/bundlers-multiple-source-security-vulnerability
bugzilla.redhat.com/show_bug.cgi?id=1381951
openwall.com/lists/oss-security/2016/10/05/3
openwall.com/lists/oss-security/2016/10/04/7
Show 9 moreShow less
openwall.com/lists/oss-security/2016/10/04/5
github.com/bundler/bundler/issues/5051
nvd.nist.gov/vuln/detail/CVE-2016-7954
github.com/rubysec/ruby-advisory-db/blob/master/gems/bundler/CVE-2016-7954.yml
web.archive.org/web/20170214030311/http://www.securityfocus.com/bid/93423
github.com/advisories/GHSA-jvgm-pfqv-887x
github.com/rubygems/bundler
ubuntu.com/security/CVE-2016-7954
cve.org/CVERecord?id=CVE-2016-7954
Left out here: 161 versions. The JSON record has them.