Every CVE Search/ Get API key

CVE-2007-6612

Mongrel vulnerable to directory traversal via double-encoded sequences

6.4 MediumFix available

Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (".%252e").

Exploit likelihood

3.00%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (".%252e").

Record
CVE-2007-6612
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:P/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (".%252e").

Record
CVE-2007-6612
Updated
2026-11-02
EUVDEUVD-2022-4514 No score

Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (".%252e").

Record
EUVD-2022-4514
Updated
2026-11-03
GitHub AdvisoriesGHSA-m7r6-43v2-49vf No score

Mongrel vulnerable to directory traversal via double-encoded sequences

Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 (1.0.3 and prior are not affected) and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (.%252e).

Record
GHSA-m7r6-43v2-49vf
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-m7r6-43v2-49vf No score

Mongrel vulnerable to directory traversal via double-encoded sequences

Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 (1.0.3 and prior are not affected) and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (.%252e).

Record
GHSA-m7r6-43v2-49vf
Weakness
CWE-22
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mongrel
RubyGems
1.0.4 to 1.0.4
1.0.5
mongrel
RubyGems
1.1.0 up to 1.1.3
1.1.3
mongrel
RubyGems
1.0.4 up to 1.0.5
1.0.5
mongrel
RubyGems
1.1.0 up to 1.1.3, plus listed versions
1.11.1.11.1.2
1.1.3

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-6612 is a medium vulnerability (CVSS 6.4) in Mongrel, published January 3, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.00%, the 87th percentile. Fixed in mongrel 1.0.5.

References

Show 11 moreShow less
MoveEnter Open