Every CVE Search/ Get API key

CVE-2006-1548

Cross-site scripting in Apache Struts

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.

Exploit likelihood

5.45%Down 2.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.

Record
CVE-2006-1548
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.

Record
CVE-2006-1548
Updated
2026-11-02
EUVDEUVD-2022-4670 No score

Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.

Record
EUVD-2022-4670
Updated
2026-11-03
GitHub AdvisoriesGHSA-p3vw-fvwx-qcv5 3.7

Cross-site scripting in Apache Struts

Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.

Record
GHSA-p3vw-fvwx-qcv5
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-p3vw-fvwx-qcv5 3.7

Cross-site scripting in Apache Struts

Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.

Record
GHSA-p3vw-fvwx-qcv5
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
struts:struts
Maven
before 1.2.9
1.2.9
struts:struts
Maven
before 1.2.9, plus listed versions
1.0.21.11.1-b2-200211241.1-b31.1-beta-2
Show 6 moreShow less
1.1-rc11.1-rc21.2.21.2.41.2.71.2.8
1.2.9

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-1548 is a medium vulnerability (CVSS 4.3) in Apache Struts, published March 30, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.45%, the 92nd percentile. Fixed in struts:struts 1.2.9.

References

Show 7 moreShow less
MoveEnter Open