CVE-2018-19295
Sylabs Singularity Improper Input Validation
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
- Record
CVE-2018-19295- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
- Record
CVE-2018-19295- Updated
- 2026-11-02
EUVDEUVD-2022-4712 No score
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
- Record
EUVD-2022-4712- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p83v-8vmr-qfv9
7.8
Sylabs Singularity Improper Input Validation
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
- Record
GHSA-p83v-8vmr-qfv9- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.8
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
- Record
CVE-2018-19295- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-p83v-8vmr-qfv9
7.8
Sylabs Singularity Improper Input Validation
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
- Record
GHSA-p83v-8vmr-qfv9- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2018-19295
7.8
Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
- Record
UBUNTU-CVE-2018-19295- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2019:0009-1 No score
Security update for singularity
This update for singularity to version 2.6.1 fixes the following issues:
Security issues fixed:
- CVE-2018-19295: Fixed a local root exploit, related to joining arbitrary mount namespaces (boo#1111411).
- Record
openSUSE-SU-2019:0009-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2019:0095-1 No score
Security update for singularity
This update for singularity to version 2.6.1 fixes the following issues:
Security issues fixed:
- CVE-2018-19295: Mount points are not mounted with shared mount propagation by default anymore, as this may result in privilege escalation (boo#1111411).
- CVE-2018-12021: Fixed a incorrect access control issues on systems supporting overlay file system (boo#1100333).
- Record
openSUSE-SU-2019:0095-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11384-1 No score
singularity-3.8.3-1.2 on GA media
These are all security issues fixed in the singularity-3.8.3-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11384-1- Updated
- 2026-11-02
OSVUSN-4840-1 No score
singularity-container vulnerabilities
It was discovered that Singularity incorrectly handled certain inputs. An attacker could possibly use this issue to obtain sensitive information. (CVE-2018-19295)
It was discovered that Singularity incorrectly handled access control. An attacker could possibly use this issue to obtain sensitive information. (CVE-2018-12021)
- Record
USN-4840-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/sylabs/singularityGo |
2.4.0 up to 2.6.1 | 2.6.1 |
singularity-containerUbuntu:Pro:18.04:LTS |
before 2.4.2-4ubuntu0.1~esm1, plus listed versions 2.3.1-22.3.2-12.4.1-12.4.2-22.4.2-32.4.2-4 |
2.4.2-4ubuntu0.1~esm1 |
singularity-containerUbuntu:Pro:18.04:LTS From an advisory covering 2 CVEs |
before 2.4.2-4ubuntu0.1~esm1, plus listed versions 2.3.1-22.3.2-12.4.1-12.4.2-22.4.2-32.4.2-4 |
2.4.2-4ubuntu0.1~esm1 |
singularitySUSE:Package Hub 15 |
before 2.6.1-bp150.3.6.1 | 2.6.1-bp150.3.6.1 |
singularityopenSUSE:Leap 15.0 |
before 2.6.1-bp150.3.6.1 | 2.6.1-bp150.3.6.1 |
singularitySUSE:Package Hub 12 SP3 From an advisory covering 2 CVEs |
before 2.6.1-14.1 | 2.6.1-14.1 |
singularityopenSUSE:Tumbleweed From an advisory covering 12 CVEs |
before 3.8.3-1.2 | 3.8.3-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-19295 is a high vulnerability (CVSS 7.8) in Sylabs Singularity, published December 17, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in github.com/sylabs/singularity 2.6.1.
References
github.com/sylabs/singularity/releases/tag/2.6.1
nvd.nist.gov/vuln/detail/CVE-2018-19295
github.com/sylabs/singularity/commit/9103f0155259fdf1159277bca3c2d347571cba0d
github.com/advisories/GHSA-p83v-8vmr-qfv9
github.com/sylabs/singularity
ubuntu.com/security/CVE-2018-19295
Show 21 moreShow less
openwall.com/lists/oss-security/2018/12/12/2
bugzilla.novell.com/show_bug.cgi?id=1111411
ubuntu.com/security/notices/USN-4840-1
cve.org/CVERecord?id=CVE-2018-19295
ubuntu.com/security/CVE-2018-12021
lists.opensuse.org/archives/list/[email protected]/thread/YGP7ICVZMBNJFA5RBXSNO3BPH73OWNQM
bugzilla.suse.com/1111411
suse.com/security/cve/CVE-2018-19295
lists.opensuse.org/archives/list/[email protected]/thread/KH5E4NYDJ6ZUYYZSVAG3DF25JMTPPTBW
bugzilla.suse.com/1100333
suse.com/security/cve/CVE-2018-12021
suse.com/security/cve/CVE-2019-11328
suse.com/security/cve/CVE-2019-19724
suse.com/security/cve/CVE-2020-13845
suse.com/security/cve/CVE-2020-13846
suse.com/security/cve/CVE-2020-13847
suse.com/security/cve/CVE-2020-15229
suse.com/security/cve/CVE-2020-25039
suse.com/security/cve/CVE-2020-25040
suse.com/security/cve/CVE-2021-29136
suse.com/security/cve/CVE-2021-32635