Every CVE Search/ Get API key

CVE-2014-5274

phpMyAdmin cross-site scripting vulnerability in crafted view name

3.5 LowFix available

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Exploit likelihood

1.02%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
CVE-2014-5274
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
CVE-2014-5274
Updated
2026-11-02
EUVDEUVD-2022-4892 No score

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
EUVD-2022-4892
Updated
2026-11-03
GitHub AdvisoriesGHSA-q586-xpwr-jc3j No score

phpMyAdmin cross-site scripting vulnerability in crafted view name

A cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
GHSA-q586-xpwr-jc3j
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
CVE-2014-5274
Updated
2026-11-02
OSVDEBIAN-CVE-2014-5274 No score

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
DEBIAN-CVE-2014-5274
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-q586-xpwr-jc3j No score

phpMyAdmin cross-site scripting vulnerability in crafted view name

A cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
GHSA-q586-xpwr-jc3j
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2014-0344 No score

Updated phpmyadmin package fixes XSS vulnerabilities

Updated phpmyadmin package fixes security vulnerabilities:

In phpMyAdmin before 4.1.14.3, multiple XSS vulnerabilities exist in browse table, ENUM editor, monitor, query charts and table relations pages (CVE-2014-5273).

In phpMyAdmin before 4.1.14.3, with a crafted view name it is possible to trigger an XSS when dropping the view in view operation page (CVE-2014-5274).

Record
MGASA-2014-0344
Updated
2026-11-02
OSVopenSUSE-SU-2024:10054-1 No score

phpMyAdmin-4.6.5.2-1.1 on GA media

These are all security issues fixed in the phpMyAdmin-4.6.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10054-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-5274 No score

Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.

Record
UBUNTU-CVE-2014-5274
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
4.1.0 up to 4.1.14.3
4.1.14.3
phpmyadmin/phpmyadmin
Packagist
4.2.0 up to 4.2.7.1
4.2.7.1
phpmyadmin
Debian:12
before 4:4.2.7.1-1
4:4.2.7.1-1
phpmyadmin
Debian:13
before 4:4.2.7.1-1
4:4.2.7.1-1
phpmyadmin
Debian:14
before 4:4.2.7.1-1
4:4.2.7.1-1
phpmyadmin
Mageia:3
From an advisory covering 2 CVEs
before 4.1.14.3-1.mga3
4.1.14.3-1.mga3
phpmyadmin
Mageia:4
From an advisory covering 2 CVEs
before 4.1.14.3-1.mga4
4.1.14.3-1.mga4
phpmyadmin
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
4:4.0.6-14:4.0.8-14:4.0.9-14:4.0.10-14:4.0.10-1ubuntu0.1
Show 4 moreShow less
4:4.0.10-1ubuntu0.1+esm14:4.0.10-1ubuntu0.1+esm24:4.0.10-1ubuntu0.1+esm34:4.0.10-1ubuntu0.1+esm4
None known
phpMyAdmin
openSUSE:Tumbleweed
From an advisory covering 124 CVEs
before 4.6.5.2-1.1
4.6.5.2-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-5274 is a low vulnerability (CVSS 3.5) in Phpmyadmin, published August 21, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in phpmyadmin/phpmyadmin 4.1.14.3.

References

Show 130 moreShow less
MoveEnter Open