Every CVE Search/ Get API key

CVE-2014-3526

Apache Wicket Sensitive Data Exposure

7.5 HighFix available

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

2.30%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Record
CVE-2014-3526
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Record
CVE-2014-3526
Updated
2026-11-02
EUVDEUVD-2022-4914 No score

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Record
EUVD-2022-4914
Updated
2026-11-03
GitHub AdvisoriesGHSA-q7wx-mhx4-jr8q 7.5

Apache Wicket Sensitive Data Exposure

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Record
GHSA-q7wx-mhx4-jr8q
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVGHSA-q7wx-mhx4-jr8q 7.5

Apache Wicket Sensitive Data Exposure

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Record
GHSA-q7wx-mhx4-jr8q
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.wicket:wicket-core
Maven
before 1.5.12
1.5.12
org.apache.wicket:wicket-core
Maven
6.0 up to 6.17.0
6.17.0
org.apache.wicket:wicket-core
Maven
7.0.0-M1 up to 7.0.0-M3
7.0.0-M3
org.apache.wicket:wicket-core
Maven
before 1.5.12, plus listed versions
1.5-RC11.5-RC31.5-RC4.21.5-RC5.11.5-RC7
Show 13 moreShow less
1.5-rc21.5.01.5.11.5.101.5.111.5.21.5.31.5.41.5.51.5.61.5.71.5.81.5.9
1.5.12
org.apache.wicket:wicket-core
Maven
6.0 up to 6.17.0, plus listed versions
6.0.06.1.06.1.16.10.06.11.0
Show 14 moreShow less
6.12.06.13.06.14.06.15.06.16.06.2.06.3.06.4.06.5.06.6.06.7.06.8.06.9.06.9.1
6.17.0
org.apache.wicket:wicket-core
Maven
7.0.0-M1 up to 7.0.0-M3, plus listed versions
7.0.0-M2
7.0.0-M3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3526 is a high vulnerability (CVSS 7.5) in Apache Wicket, published October 30, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.30%, the 83rd percentile. Fixed in org.apache.wicket:wicket-core 1.5.12.

References

MoveEnter Open