Every CVE Search/ Get API key

CVE-2014-3943

Typo3 XSS Vulnerabilities

3.5 LowFix available

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.

Exploit likelihood

1.45%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.

Record
CVE-2014-3943
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.

Record
CVE-2014-3943
Updated
2026-11-02
EUVDEUVD-2022-5016 No score

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.

Record
EUVD-2022-5016
Updated
2026-11-03
GitHub AdvisoriesGHSA-qqh2-h6gw-6x8x No score

Typo3 XSS Vulnerabilities

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.

Record
GHSA-qqh2-h6gw-6x8x
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-qqh2-h6gw-6x8x No score

Typo3 XSS Vulnerabilities

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, 6.1.0 before 6.1.9, and 6.2.0 before 6.2.3 allow remote authenticated editors to inject arbitrary web script or HTML via unknown parameters.

Record
GHSA-qqh2-h6gw-6x8x
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typo3/cms
Packagist
4.5.0 to 4.5.33
4.5.34
typo3/cms
Packagist
4.7.0 to 4.7.18
4.7.19
typo3/cms
Packagist
6.0.0 to 6.0.13
6.0.14
typo3/cms
Packagist
6.1.0 to 6.1.8
6.1.9
typo3/cms
Packagist
6.2.0 up to 6.2.3
6.2.3
typo3-src
Debian:7
From an advisory covering 6 CVEs
before 4.5.19+dfsg1-5+wheezy3, plus listed versions
4.5.19+dfsg1-54.5.19+dfsg1-5+wheezy14.5.19+dfsg1-5+wheezy2
4.5.19+dfsg1-5+wheezy3
typo3/cms
Packagist
4.5.0 up to 4.5.34
4.5.34
typo3/cms
Packagist
4.7.0 up to 4.7.19
4.7.19
typo3/cms
Packagist
6.0.0 up to 6.0.14
6.0.14
typo3/cms
Packagist
6.1.0 up to 6.1.9
6.1.9
typo3/cms
Packagist
6.2.0 up to 6.2.3, plus listed versions
6.2.16.2.2
6.2.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3943 is a low vulnerability (CVSS 3.5) in Typo3, published May 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in typo3/cms 4.5.34.

References

Show 4 moreShow less
MoveEnter Open