CVE-2022-47665
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int,...
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
- Record
CVE-2022-47665- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List
7.8
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
- Record
CVE-2022-47665- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2022-50424
7.8
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
- Record
EUVD-2022-50424- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hg94-7rm8-6vf7
7.8
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int,...
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
- Record
GHSA-hg94-7rm8-6vf7- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.8
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
- Record
CVE-2022-47665- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-47665
7.8
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
- Record
DEBIAN-CVE-2022-47665- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-47665
7.8
Libde265 1.0.9 has a heap buffer overflow vulnerability in de265_image::set_SliceAddrRS(int, int, int)
- Record
UBUNTU-CVE-2022-47665- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2023-0093 No score
Updated libde265 packages fix security vulnerability
libde265 has been updated to version 1.0.11 to fix many security issues.
- Record
MGASA-2023-0093- Updated
- 2026-11-02
OSVUSN-6659-1 No score
libde265 vulnerabilities
It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-43244, CVE-2022-43249, CVE-2022-43250, CVE-2022-47665, CVE-2023-25221)
It was discovered that libde265 could be made to read out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2022-43245)
It was discovered that libde265 could be made to dereference invalid memory. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2023-24751, CVE-2023-24752, CVE-2023-24754, CVE-2023-24755, CVE-2023-24756, CVE-2023-24757, CVE-2023-24758)
- Record
USN-6659-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libde265Debian:12 |
before 1.0.11-1 | 1.0.11-1 |
libde265Debian:13 |
before 1.0.11-1 | 1.0.11-1 |
libde265Debian:14 |
before 1.0.11-1 | 1.0.11-1 |
libde265Debian:10 From an advisory covering 10 CVEs |
before 1.0.11-0+deb10u4, plus listed versions 1.0.3-11.0.3-1+deb10u11.0.3-1+deb10u21.0.3-1+deb10u31.0.4-1 Show 5 moreShow less1.0.7-11.0.8-11.0.8-1.11.0.9-11.0.9-1.1 |
1.0.11-0+deb10u4 |
libde265Debian:11 From an advisory covering 46 CVEs |
before 1.0.11-0+deb11u1, plus listed versions 1.0.8-11.0.8-1.11.0.9-11.0.9-1.1 |
1.0.11-0+deb11u1 |
libde265Mageia:8 From an advisory covering 46 CVEs |
before 1.0.11-1.mga8 | 1.0.11-1.mga8 |
libde265Mageia:8 From an advisory covering 46 CVEs |
before 1.0.11-1.mga8.tainted | 1.0.11-1.mga8.tainted |
libde265Ubuntu:Pro:16.04:LTS |
before 1.0.2-2ubuntu0.16.04.1~esm3, plus listed versions 1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm11.0.2-2ubuntu0.16.04.1~esm2 |
1.0.2-2ubuntu0.16.04.1~esm3 |
libde265Ubuntu:Pro:18.04:LTS |
before 1.0.2-2ubuntu0.18.04.1~esm3, plus listed versions 1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm11.0.2-2ubuntu0.18.04.1~esm2 |
1.0.2-2ubuntu0.18.04.1~esm3 |
libde265Ubuntu:20.04:LTS |
before 1.0.4-1ubuntu0.3, plus listed versions 1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.11.0.4-1ubuntu0.2 |
1.0.4-1ubuntu0.3 |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
libde265Ubuntu:22.04:LTS |
before 1.0.8-1ubuntu0.2, plus listed versions 1.0.8-11.0.8-1ubuntu0.1 |
1.0.8-1ubuntu0.2 |
libde265Ubuntu:Pro:16.04:LTS From an advisory covering 13 CVEs |
before 1.0.2-2ubuntu0.16.04.1~esm3, plus listed versions 1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm11.0.2-2ubuntu0.16.04.1~esm2 |
1.0.2-2ubuntu0.16.04.1~esm3 |
libde265Ubuntu:Pro:18.04:LTS From an advisory covering 13 CVEs |
before 1.0.2-2ubuntu0.18.04.1~esm3, plus listed versions 1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm11.0.2-2ubuntu0.18.04.1~esm2 |
1.0.2-2ubuntu0.18.04.1~esm3 |
libde265Ubuntu:20.04:LTS From an advisory covering 13 CVEs |
before 1.0.4-1ubuntu0.3, plus listed versions 1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.11.0.4-1ubuntu0.2 |
1.0.4-1ubuntu0.3 |
libde265Ubuntu:22.04:LTS From an advisory covering 13 CVEs |
before 1.0.8-1ubuntu0.2, plus listed versions 1.0.8-11.0.8-1ubuntu0.1 |
1.0.8-1ubuntu0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-47665 is a high vulnerability (CVSS 7.8) in Struktur Libde265, published February 10, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 25th percentile. Fixed in libde265 1.0.11-1.
References
github.com/strukturag/libde265/issues/369
nvd.nist.gov/vuln/detail/CVE-2022-47665
github.com/advisories/GHSA-hg94-7rm8-6vf7
github.com/CVEProject/cvelistV5/tree/main/cves/2022/47xxx/CVE-2022-47665.json
security-tracker.debian.org/tracker/CVE-2022-47665
advisories.mageia.org/MGASA-2023-0093.html
Show 20 moreShow less
bugs.mageia.org/show_bug.cgi?id=31289
debian.org/lts/security/2022/dla-3240
debian.org/lts/security/2023/dla-3280
debian.org/security/2023/dsa-5346
debian.org/lts/security/2023/dla-3352
ubuntu.com/security/CVE-2022-47665
ubuntu.com/security/notices/USN-6659-1
cve.org/CVERecord?id=CVE-2022-47665
ubuntu.com/security/CVE-2022-43244
ubuntu.com/security/CVE-2022-43245
ubuntu.com/security/CVE-2022-43249
ubuntu.com/security/CVE-2022-43250
ubuntu.com/security/CVE-2023-24751
ubuntu.com/security/CVE-2023-24752
ubuntu.com/security/CVE-2023-24754
ubuntu.com/security/CVE-2023-24755
ubuntu.com/security/CVE-2023-24756
ubuntu.com/security/CVE-2023-24757
ubuntu.com/security/CVE-2023-24758
ubuntu.com/security/CVE-2023-25221