CVE-2022-4132
Memory leak on tls connections
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.9
Memory leak on tls connections
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
- Record
CVE-2022-4132- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
EUVDEUVD-2022-51497
5.9
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
- Record
EUVD-2022-51497- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hcff-4p4q-xjmc
5.9
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low...
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
- Record
GHSA-hcff-4p4q-xjmc- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
NVD
5.9
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
- Record
CVE-2022-4132- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
OSV
5.9
Memory leak on tls connections
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
- Record
CVE-2022-4132- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
OSVOESA-2025-1137
5.9
jss security update
JSS offers a implementation for java-based applications to use native NSS.
Security Fix(es):
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).(CVE-2022-4132)
- Record
OESA-2025-1137- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-4132
5.9
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
- Record
UBUNTU-CVE-2022-4132- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-4132 No score
A flaw was found in JSS. A memory leak in JSS requires non-standard configuration but is a low-effort DoS vector if configured that way (repeatedly hitting the login page).
- Record
DEBIAN-CVE-2022-4132- Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
jssDebian:12 |
All versions, plus listed versions 5.10.1-15.3.0-15.4.0-15.4.2-15.5.0-1 Show 4 moreShow less5.9.0~beta3-15.9.0~beta3-25.9.0~beta3-35.9.0~beta3-4 |
None known |
jssDebian:14 |
before 5.5.0-1, plus listed versions 4.3.1-44.3.1-54.3.1-64.3.1-74.4.2-1 Show 34 moreShow less4.4.2-24.4.2-34.4.2-44.4.2-54.4.2-64.4.3-14.4.4-14.5.0-14.5.0~a4-14.5.1-14.5.3-14.5.3-24.6.0-14.6.1-14.6.1-24.6.1-34.6.2-14.6.3-14.7.0-14.7.0~b1-14.7.0~b4-14.7.0~b4-24.7.1-14.7.2-14.7.3-14.8.0-14.8.0-24.9.1-15.0.0-15.1.0-15.2.0-15.3.0-15.4.0-15.4.2-1 |
5.5.0-1 |
jssopenEuler:24.03-LTS |
before 5.4.2-2.oe2403sp1 | 5.4.2-2.oe2403sp1 |
jssopenEuler:24.03-LTS-SP1 |
before 5.4.2-2.oe2403sp1 | 5.4.2-2.oe2403sp1 |
jssopenEuler:20.03-LTS-SP4 |
before 4.9.3-2.oe2003sp4 | 4.9.3-2.oe2003sp4 |
jssopenEuler:22.03-LTS-SP3 |
before 5.1.0-3.oe2203sp3 | 5.1.0-3.oe2203sp3 |
jssopenEuler:22.03-LTS-SP4 |
before 5.1.0-3.oe2203sp4 | 5.1.0-3.oe2203sp4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-4132 is a medium vulnerability (CVSS 5.9) in Dogtagpki Network Security Services For Java, published October 4, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 53rd percentile. Fixed in jss 5.5.0-1.
References
access.redhat.com/security/cve/CVE-2022-4132
bugzilla.redhat.com/show_bug.cgi?id=2147372
nvd.nist.gov/vuln/detail/CVE-2022-4132
github.com/advisories/GHSA-hcff-4p4q-xjmc
access.redhat.com/downloads/content/package-browser
access.redhat.com/jbossnetwork/restricted/listSoftware.html