Every CVE Search/ Get API key

CVE-2022-4198

WP Social Sharing <= 2.2 - Admin+ Stored XSS

4.8 Medium

The WP Social Sharing WordPress plugin through 2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.63%Down 0.3 points since Jan 3, 2023
90%50%10%1%

What each source reports

NVD Score used 4.8

The WP Social Sharing WordPress plugin through 2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Record
CVE-2022-4198
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
CVE List 4.8

WP Social Sharing <= 2.2 - Admin+ Stored XSS

The WP Social Sharing WordPress plugin through 2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Record
CVE-2022-4198
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
EUVDEUVD-2022-51559 4.8

The WP Social Sharing WordPress plugin through 2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Record
EUVD-2022-51559
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-6394-jqhh-rg8r 4.8

The WP Social Sharing WordPress plugin through 2.2 does not sanitise and escape some of its...

The WP Social Sharing WordPress plugin through 2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Record
GHSA-6394-jqhh-rg8r
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVopenSUSE-SU-2024:12477-1 No score

OpenImageIO-2.4.5.0-1.1 on GA media

These are all security issues fixed in the OpenImageIO-2.4.5.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12477-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
OpenImageIO
openSUSE:Tumbleweed
From an advisory covering 10 CVEs
before 2.4.5.0-1.1
2.4.5.0-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-4198 is a medium vulnerability (CVSS 4.8) in Unknown Wp Social Sharing, published January 2, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.63%, the 50th percentile. No source names a fixed version.

References

Show 8 moreShow less
MoveEnter Open