Every CVE Search/ Get API key

CVE-2022-32278

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file...

8.8 HighFix available

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.77%Down 0.8 points since Jun 14, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Record
CVE-2022-32278
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Record
CVE-2022-32278
Updated
2026-11-02
EUVDEUVD-2022-53475 No score

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Record
EUVD-2022-53475
Updated
2026-11-03
GitHub AdvisoriesGHSA-9xwj-fh68-48fj 8.8

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file...

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Record
GHSA-9xwj-fh68-48fj
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-32278 8.8

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Record
DEBIAN-CVE-2022-32278
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-32278 8.8

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Record
UBUNTU-CVE-2022-32278
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

XFCE 4.16 allows attackers to execute arbitrary code because xdg-open can execute a .desktop file on an attacker-controlled FTP server.

Record
CVE-2022-32278
Updated
2026-11-02
OSVMGASA-2022-0238 No score

Updated exo packages fix security vulnerability

Changed to prevent executing possibly malicious .desktop files from online sources (ftp://, http:// etc.).

Record
MGASA-2022-0238
Updated
2026-11-02
OSVUSN-6008-1 No score

exo vulnerability

It was discovered that Exo did not properly sanitized desktop files. A remote attacker could possibly use this issue to to cause a crash or arbitrary code execution.

Record
USN-6008-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
exo
Debian:12
before 4.16.4-1
4.16.4-1
exo
Debian:13
before 4.16.4-1
4.16.4-1
exo
Debian:14
before 4.16.4-1
4.16.4-1
exo
Debian:9
before 0.10.7-1+deb9u1, plus listed versions
0.10.7-1
0.10.7-1+deb9u1
exo
Debian:10
before 0.12.4-1+deb10u1, plus listed versions
0.12.4-1
0.12.4-1+deb10u1
exo
Debian:11
before 4.16.0-1+deb11u1, plus listed versions
4.16.0-1
4.16.0-1+deb11u1
exo
Mageia:8
before 4.16.0-1.1.mga8
4.16.0-1.1.mga8
exo
Ubuntu:Pro:14.04:LTS
before 0.10.2-3ubuntu1.14.04.2+esm1, plus listed versions
0.10.2-20.10.2-2ubuntu10.10.2-3ubuntu10.10.2-3ubuntu1.14.04.10.10.2-3ubuntu1.14.04.2
0.10.2-3ubuntu1.14.04.2+esm1
exo
Ubuntu:Pro:16.04:LTS
before 0.10.7-1ubuntu0.1~esm1, plus listed versions
0.10.7-1
0.10.7-1ubuntu0.1~esm1
exo
Ubuntu:Pro:18.04:LTS
before 0.12.2-0ubuntu0.18.04.1+esm1, plus listed versions
0.11.5-10.12.0-10.12.2-0ubuntu0.18.04.1
0.12.2-0ubuntu0.18.04.1+esm1
Show 6 moreShow less
Affected packages
PackageAffectedFixed
exo
Ubuntu:Pro:20.04:LTS
before 0.12.11-1ubuntu1.20.04.1+esm1, plus listed versions
0.12.8-10.12.11-10.12.11-1ubuntu10.12.11-1ubuntu1.20.04.1
0.12.11-1ubuntu1.20.04.1+esm1
exo
Ubuntu:Pro:22.04:LTS
before 4.16.3-1ubuntu0.1~esm1, plus listed versions
4.16.2-14.16.3-1
4.16.3-1ubuntu0.1~esm1
exo
Ubuntu:24.04:LTS
All versions, plus listed versions
4.18.0-14.18.0-1build24.18.0-1build34.18.0-1build4
None known
exo
Ubuntu:25.10
All versions, plus listed versions
4.20.0-1
None known
exo
Ubuntu:26.10
All versions, plus listed versions
4.20.0-1build1
None known
exo
Ubuntu:26.04:LTS
All versions, plus listed versions
4.20.0-14.20.0-1build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-32278 is a high vulnerability (CVSS 8.8) in Debian Linux, published June 13, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.77%, the 78th percentile. Fixed in exo 4.16.4-1.

References

Show 9 moreShow less
MoveEnter Open