Every CVE Search/ Get API key

CVE-2017-9797

Apache Geode vulnerable to Exposure of Sensitive Information

6.5 MediumFix available

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
High

Exploit likelihood

1.36%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Record
CVE-2017-9797
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:N/A:P
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Record
CVE-2017-9797
Updated
2026-11-02
EUVDEUVD-2022-5357 No score

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Record
EUVD-2022-5357
Updated
2026-11-03
GitHub AdvisoriesGHSA-vh98-fqfc-4hj3 6.5

Apache Geode vulnerable to Exposure of Sensitive Information

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Record
GHSA-vh98-fqfc-4hj3
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
Weakness
CWE-200
Updated
2026-11-02
OSV 6.5

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Record
CVE-2017-9797
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
Updated
2026-11-02
OSVGHSA-vh98-fqfc-4hj3 6.5

Apache Geode vulnerable to Exposure of Sensitive Information

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Record
GHSA-vh98-fqfc-4hj3
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.geode:geode-core
Maven
1.0.0 up to 1.2.1
1.2.1
org.apache.geode:geode-core
Maven
1.0.0 up to 1.2.1, plus listed versions
1.0.0-incubating1.0.0-incubating.M21.0.0-incubating.M31.1.01.1.11.2.0
1.2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9797 is a medium vulnerability (CVSS 6.5) in Apache Geode, published October 2, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in org.apache.geode:geode-core 1.2.1.

References

MoveEnter Open