Every CVE Search/ Get API key

CVE-2012-6145

Typo3 Backend History Module Vulnerable to XSS

3.5 LowFix available

Cross-site scripting (XSS) vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Exploit likelihood

1.18%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Cross-site scripting (XSS) vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2012-6145
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2012-6145
Updated
2026-11-02
EUVDEUVD-2022-5502 No score

Cross-site scripting (XSS) vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2022-5502
Updated
2026-11-03
GitHub AdvisoriesGHSA-w563-rq37-cvq5 No score

Typo3 Backend History Module Vulnerable to XSS

Cross-site scripting (XSS) vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-w563-rq37-cvq5
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-w563-rq37-cvq5 No score

Typo3 Backend History Module Vulnerable to XSS

Cross-site scripting (XSS) vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-w563-rq37-cvq5
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typo3/cms
Packagist
4.5.0 up to 4.5.21
4.5.21
typo3/cms
Packagist
4.6.0 up to 4.6.14
4.6.14
typo3/cms
Packagist
4.7.0 up to 4.7.6
4.7.6
typo3-src
Debian:6.0
From an advisory covering 4 CVEs
before 4.3.9+dfsg1-1+squeeze7, plus listed versions
4.3.9+dfsg1-14.3.9+dfsg1-1+squeeze14.3.9+dfsg1-1+squeeze24.3.9+dfsg1-1+squeeze34.3.9+dfsg1-1+squeeze44.3.9+dfsg1-1+squeeze54.3.9+dfsg1-1+squeeze6
4.3.9+dfsg1-1+squeeze7

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-6145 is a low vulnerability (CVSS 3.5) in Typo3, published November 15, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.18%, the 67th percentile. Fixed in typo3/cms 4.5.21.

References

MoveEnter Open