Every CVE Search/ Get API key

CVE-2020-2186

CSRF vulnerability in Amazon EC2 Plugin

4.3 MediumFix available

A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.50.1 and earlier allows attackers to provision instances.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.64%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.3

A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.50.1 and earlier allows attackers to provision instances.

Record
CVE-2020-2186
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.50.1 and earlier allows attackers to provision instances.

Record
CVE-2020-2186
Updated
2026-11-02
EUVDEUVD-2022-5512 No score

A cross-site request forgery vulnerability in Jenkins Amazon EC2 Plugin 1.50.1 and earlier allows attackers to provision instances.

Record
EUVD-2022-5512
Updated
2026-11-03
GitHub AdvisoriesGHSA-w6hw-57jq-h7f5 3.1

CSRF vulnerability in Amazon EC2 Plugin

Amazon EC2 Plugin 1.50.1 and earlier does not require POST requests in several HTTP endpoints, resulting in cross-site request forgery (CSRF) vulnerabilities. This allows an attacker to provision instances with an attacker-specified template ID.

Amazon EC2 Plugin 1.50.2 now requires POST requests for the affected HTTP endpoints.

Record
GHSA-w6hw-57jq-h7f5
CVSS 3.0
3.1 LowCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-w6hw-57jq-h7f5 3.1

CSRF vulnerability in Amazon EC2 Plugin

Amazon EC2 Plugin 1.50.1 and earlier does not require POST requests in several HTTP endpoints, resulting in cross-site request forgery (CSRF) vulnerabilities. This allows an attacker to provision instances with an attacker-specified template ID.

Amazon EC2 Plugin 1.50.2 now requires POST requests for the affected HTTP endpoints.

Record
GHSA-w6hw-57jq-h7f5
CVSS 3.0
3.1 LowCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.jenkins-ci.plugins:ec2
Maven
through 1.50.1
1.50.2
org.jenkins-ci.plugins:ec2
Maven
before 1.50.2, plus listed versions
1.111.121.131.141.15
Show 45 moreShow less
1.161.171.181.191.201.211.221.231.241.251.261.271.281.291.301.311.321.331.341.351.361.371.381.391.401.40.11.411.41.11.421.42.11.42.21.431.441.44.11.451.461.46.11.46.21.46.31.46.41.471.481.491.49.11.49.2
1.50.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-2186 is a medium vulnerability (CVSS 4.3) in Jenkins Amazon Ec2, published May 6, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.64%, the 50th percentile. Fixed in org.jenkins-ci.plugins:ec2 1.50.2.

References

This page doesn't list everything

Left out here: 3 versions. The JSON record has them.

MoveEnter Open