CVE-2013-2082
Moodle does not enforce capability requirements for reading blog comments
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.
Exploit likelihood
What each source reports
NVD Score used
5.0
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.
- Record
CVE-2013-2082- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.
- Record
CVE-2013-2082- Updated
- 2026-11-02
EUVDEUVD-2022-5609 No score
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.
- Record
EUVD-2022-5609- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wp3g-pr4h-q6vv No score
Moodle does not enforce capability requirements for reading blog comments
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.
- Record
GHSA-wp3g-pr4h-q6vv- Updated
- 2026-11-02
OSVGHSA-wp3g-pr4h-q6vv No score
Moodle does not enforce capability requirements for reading blog comments
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.
- Record
GHSA-wp3g-pr4h-q6vv- Updated
- 2026-11-02
OSVMGASA-2013-0162 No score
Updated moodle package fix security vulnerabilities
The assignment module in Moodle before 2.4.4 was not checking capabilities for users downloading all assignments as a zip (CVE-2013-2079).
The Gradebook's Overview report in Moodle before 2.4.4 was showing grade totals that may have incorrectly included hidden grades (CVE-2013-2080).
When registering a site on a hub (not Moodle.net) site in Moodle before 2.4.4, information was being sent to the hub regardless of settings chosen (CVE-2013-2081).
There was no check of permissions for viewing comments on blog posts in Moodle before 2.4.4 (CVE-2013-2082).
Form elements named using a specific naming scheme were not being filtered correctly in Moodle before 2.4.4 (CVE-2013-2083).
- Record
MGASA-2013-0162- Updated
- 2026-11-02
OSVUBUNTU-CVE-2013-2082 No score
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.
- Record
UBUNTU-CVE-2013-2082- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.2.10 | 2.2.10 |
moodle/moodlePackagist |
2.3.0 up to 2.3.7 | 2.3.7 |
moodle/moodlePackagist |
2.4.0 up to 2.4.4 | 2.4.4 |
moodle/moodlePackagist |
2.3.0 up to 2.3.7, plus listed versions v2.3.4v2.3.5v2.3.6 |
2.3.7 |
moodle/moodlePackagist |
2.4.0 up to 2.4.4, plus listed versions v2.4.0v2.4.1v2.4.2v2.4.3 |
2.4.4 |
moodleMageia:3 From an advisory covering 5 CVEs |
before 2.4.4-1.1.mga3 | 2.4.4-1.1.mga3 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-2082 is a medium vulnerability (CVSS 5.0) in Moodle, published May 25, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in moodle/moodle 2.2.10.
References
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-37245
lists.fedoraproject.org/pipermail/package-announce/2013-May/106965.html
openwall.com/lists/oss-security/2013/05/21/1
lists.fedoraproject.org/pipermail/package-announce/2013-May/107026.html
moodle.org/mod/forum/discuss.php?d=228934
lists.fedoraproject.org/pipermail/package-announce/2013-May/106988.html
Show 18 moreShow less
nvd.nist.gov/vuln/detail/CVE-2013-2082
github.com/moodle/moodle/commit/28772fb9e7e6be01b765fb721af16901bb47e417
github.com/moodle/moodle/commit/5fde58a59335bc3109a9eaac4a15d1e9217541c3
github.com/moodle/moodle/commit/8aa12adcf26ff2f0b61cd6f0288f2886c8c55bf7
github.com/moodle/moodle/commit/9a909b1a359f72b8d384e18da8e05474604279e1
github.com/moodle/moodle/commit/cb538f0e539e833edb7cf6fa3d705e8abc5003fd
github.com/moodle/moodle/commit/f9e27e8323f31186820d25252ec0d4c6cd65dafc
github.com/advisories/GHSA-wp3g-pr4h-q6vv
github.com/moodle/moodle
advisories.mageia.org/MGASA-2013-0162.html
moodle.org/mod/forum/discuss.php?d=228930
moodle.org/mod/forum/discuss.php?d=228931
moodle.org/mod/forum/discuss.php?d=228933
moodle.org/mod/forum/discuss.php?d=228935
docs.moodle.org/dev/Moodle_2.4.4_release_notes
moodle.org/mod/forum/discuss.php?d=228536
ubuntu.com/security/CVE-2013-2082
cve.org/CVERecord?id=CVE-2013-2082