CVE-2019-10325
Jenkins Warnings NG Plugin Cross-site scripting vulnerability
A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.
- Record
CVE-2019-10325- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.
- Record
CVE-2019-10325- Updated
- 2026-11-02
EUVDEUVD-2022-5633 No score
A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.
- Record
EUVD-2022-5633- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wrr5-p265-7252
5.4
Jenkins Warnings NG Plugin Cross-site scripting vulnerability
A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.
- Record
GHSA-wrr5-p265-7252- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.
- Record
CVE-2019-10325- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-wrr5-p265-7252
5.4
Jenkins Warnings NG Plugin Cross-site scripting vulnerability
A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.
- Record
GHSA-wrr5-p265-7252- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
io.jenkins.plugins:warnings-ngMaven |
through 5.0.0 | 5.1.0 |
io.jenkins.plugins:warnings-ngMaven |
before 5.1.0, plus listed versions 1.0.01.0.0-beta11.0.0-beta101.0.0-beta21.0.0-beta3 Show 18 moreShow less1.0.0-beta41.0.0-beta51.0.0-beta61.0.0-beta71.0.0-beta81.0.0-beta91.0.12.0.02.1.02.1.12.1.22.2.02.2.13.0.03.0.13.0.34.0.05.0.0 |
5.1.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-10325 is a medium vulnerability (CVSS 5.4) in Jenkins Project Warnings Ng Plugin, published May 31, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in io.jenkins.plugins:warnings-ng 5.1.0.