Every CVE Search/ Get API key

CVE-2022-35649

Moodle PostScript Code Injection

9.8 CriticalPublic exploitFix available

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

8.55%Up 4.1 points since Jul 26, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
CVE-2022-35649
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94, CWE-20
Updated
2026-11-02
CVE List No score

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
CVE-2022-35649
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2022-6451 No score

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
EUVD-2022-6451
Updated
2026-11-03
GitHub AdvisoriesGHSA-xp2f-9mx3-3c6p 9.8

Moodle PostScript Code Injection

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
GHSA-xp2f-9mx3-3c6p
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-xp2f-9mx3-3c6p 9.8

Moodle PostScript Code Injection

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
GHSA-xp2f-9mx3-3c6p
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2022-35649 9.8

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
UBUNTU-CVE-2022-35649
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-moodle-2022-35649 No score

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
BIT-moodle-2022-35649
Updated
2026-11-02
OSV No score

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Record
CVE-2022-35649
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.9 up to 3.9.15
3.9.15
moodle/moodle
Packagist
3.11 up to 3.11.8
3.11.8
moodle/moodle
Packagist
4.0 up to 4.0.2
4.0.2
moodle
Bitnami
3.9.0 up to 3.9.15, 3.11.0 up to 3.11.8, 4.0.0 up to 4.0.2
3.9.153.11.84.0.2
moodle/moodle
Packagist
3.9 up to 3.9.15, plus listed versions
v3.9.0v3.9.0-betav3.9.0-rc1v3.9.0-rc2v3.9.0-rc3
Show 14 moreShow less
v3.9.1v3.9.10v3.9.11v3.9.12v3.9.13v3.9.14v3.9.2v3.9.3v3.9.4v3.9.5v3.9.6v3.9.7v3.9.8v3.9.9
3.9.15
moodle/moodle
Packagist
3.11 up to 3.11.8, plus listed versions
v3.11.0v3.11.0-betav3.11.0-rc1v3.11.0-rc2v3.11.1
Show 6 moreShow less
v3.11.2v3.11.3v3.11.4v3.11.5v3.11.6v3.11.7
3.11.8
moodle/moodle
Packagist
4.0 up to 4.0.2, plus listed versions
v4.0.0v4.0.0-betav4.0.0-rc1v4.0.0-rc2v4.0.0-rc3v4.0.0-rc4v4.0.1
4.0.2
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubantoinenguyen-09/CVE-2022-356492023-03-06

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-35649 is a critical vulnerability (CVSS 9.8) in Moodle, published July 25, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.55%, the 95th percentile. Fixed in moodle/moodle 3.9.15.

References

Show 7 moreShow less
MoveEnter Open