CVE-2022-39198
Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
- Record
CVE-2022-39198- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List
9.8
Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
- Record
CVE-2022-39198- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
EUVDEUVD-2022-7031
9.8
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
- Record
EUVD-2022-7031- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5qwq-g2hx-r6f7
9.8
Hessian Lite for Apache Dubbo deserialization vulnerability
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
- Record
GHSA-5qwq-g2hx-r6f7- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
9.8
Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
- Record
CVE-2022-39198- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSVGHSA-5qwq-g2hx-r6f7
9.8
Hessian Lite for Apache Dubbo deserialization vulnerability
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
- Record
GHSA-5qwq-g2hx-r6f7- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
com.alibaba:hessian-liteMaven |
through 3.2.12 | 3.2.13 |
org.apache.dubbo:dubboMaven |
2.7.0 to 2.7.17 | 2.7.18 |
org.apache.dubbo:dubboMaven |
3.0.0 to 3.0.11 | 3.0.12 |
org.apache.dubbo:dubboMaven |
3.1.0 to 3.1.0 | 3.1.1 |
com.alibaba:hessian-liteMaven |
before 3.2.13, plus listed versions 2.6.23.2.103.2.113.2.123.2.2 Show 7 moreShow less3.2.33.2.43.2.53.2.63.2.73.2.83.2.9 |
3.2.13 |
org.apache.dubbo:dubboMaven |
2.7.0 up to 2.7.18, plus listed versions 2.7.12.7.102.7.112.7.122.7.13 Show 13 moreShow less2.7.142.7.152.7.162.7.172.7.22.7.32.7.42.7.4.12.7.52.7.62.7.72.7.82.7.9 |
2.7.18 |
org.apache.dubbo:dubboMaven |
3.0.0 up to 3.0.12, plus listed versions 3.0.0.preview3.0.13.0.103.0.113.0.2 Show 8 moreShow less3.0.2.13.0.33.0.43.0.53.0.63.0.73.0.83.0.9 |
3.0.12 |
org.apache.dubbo:dubboMaven |
3.1.0 up to 3.1.1 | 3.1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-39198 is a critical vulnerability (CVSS 9.8) in Apache Dubbo, published October 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.31%, the 88th percentile. Fixed in com.alibaba:hessian-lite 3.2.13.
References
lists.apache.org/thread/8d3zqrkoy4jh8dy37j4rd7g9jodzlvkk
nvd.nist.gov/vuln/detail/CVE-2022-39198
github.com/apache/dubbo-hessian-lite/releases/tag/v3.2.13
github.com/apache/dubbo/releases/tag/dubbo-2.7.18
github.com/apache/dubbo/releases/tag/dubbo-3.0.12
github.com/apache/dubbo/releases/tag/dubbo-3.1.1
github.com/advisories/GHSA-5qwq-g2hx-r6f7
github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39198.json
github.com/apache/dubbo-hessian-lite