CVE-2022-39340
OpenFGA Information Disclosure
OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the streamed-list-objects endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users openfga/openfga versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.3
OpenFGA Information Disclosure
OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the streamed-list-objects endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users openfga/openfga versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
CVE-2022-39340- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2022-7062
5.3
OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the streamed-list-objects endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users openfga/openfga versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
EUVD-2022-7062- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-95x7-mh78-7w2r
5.3
OpenFGA subject to Information Disclosure via streamed-list-objects endpoint
Overview
During our internal security assessment, it was discovered that streamed-list-objects endpoint was not validating the authorization header resulting in the disclosure of objects in the store.
Am I Affected?
You are affected by this vulnerability if you are using openfga/openfga version v0.2.3 or prior and you are exposing the OpenFGA service to the internet.
How to fix that?
Upgrade to version v0.2.4.
Backward Compatibility
This update is backward compatible.
- Record
GHSA-95x7-mh78-7w2r- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-285, CWE-862, CWE-863
- Updated
- 2026-11-02
NVD
5.3
OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the streamed-list-objects endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users openfga/openfga versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
CVE-2022-39340- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-285, CWE-862
- Updated
- 2026-11-02
OSV
5.3
OpenFGA Information Disclosure
OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the streamed-list-objects endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users openfga/openfga versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
CVE-2022-39340- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-95x7-mh78-7w2r
5.3
OpenFGA subject to Information Disclosure via streamed-list-objects endpoint
Overview
During our internal security assessment, it was discovered that streamed-list-objects endpoint was not validating the authorization header resulting in the disclosure of objects in the store.
Am I Affected?
You are affected by this vulnerability if you are using openfga/openfga version v0.2.3 or prior and you are exposing the OpenFGA service to the internet.
How to fix that?
Upgrade to version v0.2.4.
Backward Compatibility
This update is backward compatible.
- Record
GHSA-95x7-mh78-7w2r- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-285, CWE-862, CWE-863
- Updated
- 2026-11-02
OSVGO-2022-1079 No score
OpenFGA subject to Information Disclosure via streamed-list-objects endpoint in github.com/openfga/openfga
OpenFGA subject to Information Disclosure via streamed-list-objects endpoint in github.com/openfga/openfga
- Record
GO-2022-1079- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/openfga/openfgaGo |
through 0.2.3 | 0.2.4 |
github.com/openfga/openfgaGo |
before 0.2.4 | 0.2.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-39340 is a medium vulnerability (CVSS 5.3) in Openfga, published October 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.91%, the 60th percentile. Fixed in github.com/openfga/openfga 0.2.4.
References
github.com/openfga/openfga/releases/tag/v0.2.4
github.com/openfga/openfga/security/advisories/GHSA-95x7-mh78-7w2r
github.com/openfga/openfga/commit/779d73d4b6d067ee042ec9b59fec707eed71e42f
nvd.nist.gov/vuln/detail/CVE-2022-39340
github.com/advisories/GHSA-95x7-mh78-7w2r
github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39340.json
github.com/openfga/openfga