CVE-2022-38146
URL XSS vulnerability due to outdated jquery in CMS
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
- Record
CVE-2022-38146- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List
5.4
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
- Record
CVE-2022-38146- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-7221
5.4
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
- Record
EUVD-2022-7221- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-44xv-v98g-v79f
5.4
URL XSS vulnerability due to outdated jquery in CMS
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
- Record
GHSA-44xv-v98g-v79f- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
- Record
CVE-2022-38146- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-44xv-v98g-v79f
5.4
URL XSS vulnerability due to outdated jquery in CMS
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
- Record
GHSA-44xv-v98g-v79f- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
silverstripe/adminPackagist |
1.0.0 up to 1.11.3 | 1.11.3 |
silverstripe/adminPackagist |
1.0.0 up to 1.11.3, plus listed versions 1.0.11.0.1-rc11.0.21.0.31.0.4 Show 45 moreShow less1.0.51.0.61.0.71.1.01.1.0-rc11.1.0-rc21.1.11.1.21.1.31.1.41.1.51.10.01.10.0-beta11.10.0-rc11.10.11.10.21.10.31.10.41.11.01.11.0-beta11.11.0-rc11.11.11.11.21.2.01.2.0-beta11.2.11.2.21.2.31.2.41.2.51.2.61.3.01.3.0-rc11.3.11.3.21.3.31.3.41.3.51.4.01.4.0-rc11.4.11.4.21.4.31.4.41.4.5 |
1.11.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-38146 is a medium vulnerability (CVSS 5.4) in Silverstripe Framework, published November 21, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.58%, the 48th percentile. Fixed in silverstripe/admin 1.11.3.
References
silverstripe.org/download/security-releases
silverstripe.org/blog/tag/release
forum.silverstripe.org/c/releases
silverstripe.org/download/security-releases/CVE-2022-38146
nvd.nist.gov/vuln/detail/CVE-2022-38146
github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/admin/CVE-2022-38146.yaml
github.com/advisories/GHSA-44xv-v98g-v79f
github.com/CVEProject/cvelistV5/tree/main/cves/2022/38xxx/CVE-2022-38146.json
Left out here: 28 versions. The JSON record has them.