Every CVE Search/ Get API key

CVE-2022-4863

Improper Handling of Insufficient Permissions or Privileges in usememos/memos

8.4 HighFix available

Improper Handling of Insufficient Permissions or Privileges in GitHub repository usememos/memos prior to 0.9.1.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.73%Down 0.2 points since Dec 31, 2022
90%50%10%1%

What each source reports

CVE List Score used 8.4

Improper Handling of Insufficient Permissions or Privileges in usememos/memos

Improper Handling of Insufficient Permissions or Privileges in GitHub repository usememos/memos prior to 0.9.1.

Record
CVE-2022-4863
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-280
Updated
2026-11-02
EUVDEUVD-2022-7544 8.4

Improper Handling of Insufficient Permissions or Privileges in GitHub repository usememos/memos prior to 0.9.1.

Record
EUVD-2022-7544
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-6whj-8g9g-5jvx 6.5

usememos/memos vulnerable to Improper Handling of Insufficient Permissions or Privileges

Improper Handling of Insufficient Permissions or Privileges in GitHub repository usememos/memos prior to 0.9.1.

Record
GHSA-6whj-8g9g-5jvx
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-280
Updated
2026-11-02
NVD 6.5

Improper Handling of Insufficient Permissions or Privileges in GitHub repository usememos/memos prior to 0.9.1.

Record
CVE-2022-4863
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-280
Updated
2026-11-02
OSV 8.4

Improper Handling of Insufficient Permissions or Privileges in usememos/memos

Improper Handling of Insufficient Permissions or Privileges in GitHub repository usememos/memos prior to 0.9.1.

Record
CVE-2022-4863
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-280
Updated
2026-11-02
OSVGHSA-6whj-8g9g-5jvx 6.5

usememos/memos vulnerable to Improper Handling of Insufficient Permissions or Privileges

Improper Handling of Insufficient Permissions or Privileges in GitHub repository usememos/memos prior to 0.9.1.

Record
GHSA-6whj-8g9g-5jvx
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-280
Updated
2026-11-02
OSVGO-2023-1270 No score

usememos/memos vulnerable to Improper Handling of Insufficient Permissions or Privileges in github.com/usememos/memos

usememos/memos vulnerable to Improper Handling of Insufficient Permissions or Privileges in github.com/usememos/memos

Record
GO-2023-1270
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/usememos/memos
Go
before 0.9.1
0.9.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-4863 is a high vulnerability (CVSS 8.4) in Usememos Memos, published December 30, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.73%, the 54th percentile. Fixed in github.com/usememos/memos 0.9.1.

References

MoveEnter Open