CVE-2022-4865
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
8.3
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4865- CVSS 3.0
- 8.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-7571
8.3
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
EUVD-2022-7571- CVSS 3.0
- 8.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8w5q-5fpq-v4pm
9.0
usememos/memos Cross-site Scripting vulnerability
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
GHSA-8w5q-5fpq-v4pm- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
9.0
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4865- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - CVSS 3.0
- 8.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
8.3
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4865- CVSS 3.0
- 8.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-8w5q-5fpq-v4pm
9.0
usememos/memos Cross-site Scripting vulnerability
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
GHSA-8w5q-5fpq-v4pm- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/usememos/memosGo |
before 0.9.1 | 0.9.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-4865 is a high vulnerability (CVSS 8.3) in Usememos Memos, published December 31, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in github.com/usememos/memos 0.9.1.
References
github.com/usememos/memos/commit/7670c9536000bb32c6345d4906a91268dcddd5fc
huntr.dev/bounties/cd8765a2-bf28-4019-8647-882ccf63b2be
nvd.nist.gov/vuln/detail/CVE-2022-4865
github.com/advisories/GHSA-8w5q-5fpq-v4pm
github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4865.json
github.com/usememos/memos