CVE-2022-4866
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4866- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-7772
9.8
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
EUVD-2022-7772- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x9p9-v3x6-68mq
9.0
usememos/memos vulnerable to Cross-site Scripting
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
GHSA-x9p9-v3x6-68mq- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
9.0
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4866- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
9.8
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4866- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-x9p9-v3x6-68mq
9.0
usememos/memos vulnerable to Cross-site Scripting
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
- Record
GHSA-x9p9-v3x6-68mq- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/usememos/memosGo |
before 0.9.1 | 0.9.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-4866 is a critical vulnerability (CVSS 9.8) in Usememos Memos, published December 31, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in github.com/usememos/memos 0.9.1.
References
huntr.dev/bounties/39c04778-6228-4f07-bdd4-ab17f246dbff
github.com/usememos/memos/commit/7670c9536000bb32c6345d4906a91268dcddd5fc
nvd.nist.gov/vuln/detail/CVE-2022-4866
github.com/advisories/GHSA-x9p9-v3x6-68mq
github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4866.json
github.com/usememos/memos