Every CVE Search/ Get API key

CVE-2021-41144

OpenMage LTS authenticated remote code execution through layout update

8.8 HighFix available

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, a layout block was able to bypass the block blacklist to execute remote code. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.22%Up 0.3 points since Jan 28, 2023
90%50%10%1%

What each source reports

CVE List Score used 8.8

OpenMage LTS authenticated remote code execution through layout update

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, a layout block was able to bypass the block blacklist to execute remote code. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Record
CVE-2021-41144
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
EUVDEUVD-2023-0340 8.8

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, a layout block was able to bypass the block blacklist to execute remote code. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Record
EUVD-2023-0340
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-5j2g-3ph4-rgvm 8.8

Fix for authenticated remote code execution through layout update

Impact

A layout block was able to bypass the block blacklist to execute remote code.

Record
GHSA-5j2g-3ph4-rgvm
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
NVD 8.8

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, a layout block was able to bypass the block blacklist to execute remote code. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Record
CVE-2021-41144
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSV 8.8

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, a layout block was able to bypass the block blacklist to execute remote code. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Record
CVE-2021-41144
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-5j2g-3ph4-rgvm 8.8

Fix for authenticated remote code execution through layout update

Impact

A layout block was able to bypass the block blacklist to execute remote code.

Record
GHSA-5j2g-3ph4-rgvm
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openmage/magento-lts
Packagist
before 19.4.22
19.4.22
openmage/magento-lts
Packagist
20.0.0 up to 20.0.19
20.0.19
openmage/magento-lts
Packagist
before 19.4.22, plus listed versions
1.9.1.11.9.2.01.9.2.11.9.2.21.9.2.3
Show 25 moreShow less
1.9.2.41.9.3.01.9.3.1v19.4.0v19.4.1v19.4.10v19.4.11v19.4.12v19.4.13v19.4.14v19.4.15v19.4.16v19.4.17v19.4.18v19.4.19v19.4.2v19.4.20v19.4.21v19.4.3v19.4.4v19.4.5v19.4.6v19.4.7v19.4.8v19.4.9
19.4.22
openmage/magento-lts
Packagist
20.0.0 up to 20.0.19, plus listed versions
v20.0.0v20.0.1v20.0.10v20.0.11v20.0.12
Show 13 moreShow less
v20.0.13v20.0.14v20.0.15v20.0.16v20.0.17v20.0.18v20.0.2v20.0.3v20.0.4v20.0.5v20.0.6v20.0.7v20.0.8
20.0.19

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-41144 is a high vulnerability (CVSS 8.8) in Openmage Magento, published January 27, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.22%, the 68th percentile. Fixed in openmage/magento-lts 19.4.22.

References

MoveEnter Open