CVE-2023-0569
Weak Password Requirements in publify/publify
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.1
Weak Password Requirements in publify/publify
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2023-0569- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-521
- Updated
- 2026-11-02
EUVDEUVD-2023-0471
8.1
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
- Record
EUVD-2023-0471- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-g7gf-2rqw-5rwx
6.5
Publify contains Weak Password Requirements
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
- Record
GHSA-g7gf-2rqw-5rwx- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-521
- Updated
- 2026-11-02
NVD
6.5
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2023-0569- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-521
- Updated
- 2026-11-02
OSV
8.1
Weak Password Requirements in publify/publify
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2023-0569- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-521
- Updated
- 2026-11-02
OSVGHSA-g7gf-2rqw-5rwx
6.5
Publify contains Weak Password Requirements
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
- Record
GHSA-g7gf-2rqw-5rwx- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-521
- Updated
- 2026-11-02
OSVBIT-publify-2023-0569 No score
Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.
- Record
BIT-publify-2023-0569- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.10 | 9.2.10 |
publifyBitnami |
before 9.2.10 | 9.2.10 |
publify_coreRubyGems |
before 9.2.10, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 14 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.79.2.89.2.9 |
9.2.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-0569 is a high vulnerability (CVSS 8.1) in Publify Publify/publify, published January 29, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.70%, the 53rd percentile. Fixed in publify_core 9.2.10.
References
huntr.dev/bounties/81b1e1da-10dd-435e-94ae-4bdd41df6df9
github.com/publify/publify/commit/8905e4e639cf03b758da558568a86c9816253b2d
huntr.com/bounties/81b1e1da-10dd-435e-94ae-4bdd41df6df9
nvd.nist.gov/vuln/detail/CVE-2023-0569
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2023-0569.yml
github.com/advisories/GHSA-g7gf-2rqw-5rwx
github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0569.json
github.com/publify/publify