CVE-2022-47551
Apiman has potential permissions bypass
Apiman 1.5.7 through 2.2.3.Final has insufficient checks for read permissions within the Apiman Manager REST API. The root cause of the issue is the Apiman project's accidental acceptance of a large contribution that was not fully compatible with the security model of Apiman versions before 3.0.0.Final. Because of this, 3.0.0.Final is not affected by the vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Apiman 1.5.7 through 2.2.3.Final has insufficient checks for read permissions within the Apiman Manager REST API. The root cause of the issue is the Apiman project's accidental acceptance of a large contribution that was not fully compatible with the security model of Apiman versions before 3.0.0.Final. Because of this, 3.0.0.Final is not affected by the vulnerability.
- Record
CVE-2022-47551- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-276
- Updated
- 2026-11-02
CVE List
6.5
Apiman 1.5.7 through 2.2.3.Final has insufficient checks for read permissions within the Apiman Manager REST API. The root cause of the issue is the Apiman project's accidental acceptance of a large contribution that was not fully compatible with the security model of Apiman versions before 3.0.0.Final. Because of this, 3.0.0.Final is not affected by the vulnerability.
- Record
CVE-2022-47551- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-276
- Updated
- 2026-11-02
EUVDEUVD-2023-0494
6.5
Apiman 1.5.7 through 2.2.3.Final has insufficient checks for read permissions within the Apiman Manager REST API. The root cause of the issue is the Apiman project's accidental acceptance of a large contribution that was not fully compatible with the security model of Apiman versions before 3.0.0.Final. Because of this, 3.0.0.Final is not affected by the vulnerability.
- Record
EUVD-2023-0494- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-j94p-hv25-rm5g
7.1
Apiman has potential permissions bypass
Impact
Incorrect default permissions for certain read-only resources in the Apiman 1.5.7.Final through 2.2.3.Final in the Apiman Manager REST API allows a remote authenticated attacker to access information and resources in an Apiman Organizations they are not a member of and/or do not have permissions for.
For example, an attacker may be able to craft an HTTP request to discover APIs that are private to organizations they are not members of, via fuzzing, search, and other similar mechanisms.
If the attacker has sufficient permissions in their own organization, they may also be able to sign up to the private APIs they have discovered by crafting a tailored HTTP request, thereby gaining access to an API Management protected resource that they should have access to.
-
A malicious account-holder may be able to see information about APIs they do not have permission for.
-
A malicious account-holder may be able to sign up to APIs they do not have permission for, and hence access API Management-protected resources they are not authorized to access.
-
This does NOT relate to the Apiman Gateway.
Patches
-
Upgrade to Apiman 3.0.0.Final (or later). The issue is fixed in this version.
-
If you are using an older version of Apiman, contact to your Apiman support provider for advice/long-term support.
References
- Record
GHSA-j94p-hv25-rm5g- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Updated
- 2026-11-02
OSV
6.5
Apiman 1.5.7 through 2.2.3.Final has insufficient checks for read permissions within the Apiman Manager REST API. The root cause of the issue is the Apiman project's accidental acceptance of a large contribution that was not fully compatible with the security model of Apiman versions before 3.0.0.Final. Because of this, 3.0.0.Final is not affected by the vulnerability.
- Record
CVE-2022-47551- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-j94p-hv25-rm5g
7.1
Apiman has potential permissions bypass
Impact
Incorrect default permissions for certain read-only resources in the Apiman 1.5.7.Final through 2.2.3.Final in the Apiman Manager REST API allows a remote authenticated attacker to access information and resources in an Apiman Organizations they are not a member of and/or do not have permissions for.
For example, an attacker may be able to craft an HTTP request to discover APIs that are private to organizations they are not members of, via fuzzing, search, and other similar mechanisms.
If the attacker has sufficient permissions in their own organization, they may also be able to sign up to the private APIs they have discovered by crafting a tailored HTTP request, thereby gaining access to an API Management protected resource that they should have access to.
-
A malicious account-holder may be able to see information about APIs they do not have permission for.
-
A malicious account-holder may be able to sign up to APIs they do not have permission for, and hence access API Management-protected resources they are not authorized to access.
-
This does NOT relate to the Apiman Gateway.
Patches
-
Upgrade to Apiman 3.0.0.Final (or later). The issue is fixed in this version.
-
If you are using an older version of Apiman, contact to your Apiman support provider for advice/long-term support.
References
- Record
GHSA-j94p-hv25-rm5g- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
io.apiman:apiman-manager-api-rest-implMaven |
1.5.7 to 2.2.3.Final | 3.0.0.Final |
io.apiman:apiman-manager-api-rest-implMaven |
1.5.7 up to 3.0.0.Final, plus listed versions 1.5.7.Final2.0.0.Final2.1.0.Final2.1.1.Final2.1.2.Final Show 8 moreShow less2.1.3.Final2.1.4.Final2.1.5.Final2.2.0.Final2.2.1.Final2.2.2.Final2.2.3.Final3.0.0.RC6 |
3.0.0.Final |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-47551 is a medium vulnerability (CVSS 6.5) in Apiman, published December 19, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.64%, the 51st percentile. Fixed in io.apiman:apiman-manager-api-rest-impl 3.0.0.Final.
References
github.com/apiman/apiman
apiman.io/blog/permissions-bypass-disclosure
github.com/apiman/apiman/security/advisories/GHSA-j94p-hv25-rm5g
nvd.nist.gov/vuln/detail/CVE-2022-47551
github.com/advisories/GHSA-54r5-wr8x-x5v3
github.com/orgs/apiman/discussions/2409
github.com/advisories/GHSA-j94p-hv25-rm5g
github.com/CVEProject/cvelistV5/tree/main/cves/2022/47xxx/CVE-2022-47551.json