CVE-2022-1812
Integer Overflow or Wraparound in publify/publify
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.6
Integer Overflow or Wraparound in publify/publify
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2022-1812- CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
EUVDEUVD-2023-0543
7.6
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
- Record
EUVD-2023-0543- CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-rc42-jghf-vr8f
9.8
Integer overflow in publify_core
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10 due to an unlimited length user name field.
- Record
GHSA-rc42-jghf-vr8f- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
NVD
9.8
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2022-1812- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
7.6
Integer Overflow or Wraparound in publify/publify
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2022-1812- CVSS 3.0
- 7.6 High
CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSVGHSA-rc42-jghf-vr8f
9.8
Integer overflow in publify_core
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10 due to an unlimited length user name field.
- Record
GHSA-rc42-jghf-vr8f- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSVBIT-publify-2022-1812 No score
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
- Record
BIT-publify-2022-1812- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.10 | 9.2.10 |
publifyBitnami |
before 9.2.10 | 9.2.10 |
publify_coreRubyGems |
before 9.2.10, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 14 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.79.2.89.2.9 |
9.2.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-1812 is a high vulnerability (CVSS 7.6) in Publify Publify/publify, published January 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 30.8%, the 98th percentile. Fixed in publify_core 9.2.10.
References
huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3
github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e41a
nvd.nist.gov/vuln/detail/CVE-2022-1812
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2022-1812.yml
github.com/advisories/GHSA-rc42-jghf-vr8f
github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1812.json
github.com/publify/publify_core