Every CVE Search/ Get API key

CVE-2009-4123

jruby-openssl gem for JRuby fails to do proper certificate validation

7.5 HighFix available

The jruby-openssl gem before 0.6 for JRuby mishandles SSL certificate validation.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.60%Up 0.6 points since Dec 13, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

The jruby-openssl gem before 0.6 for JRuby mishandles SSL certificate validation.

Record
CVE-2009-4123
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

The jruby-openssl gem before 0.6 for JRuby mishandles SSL certificate validation.

Record
CVE-2009-4123
Updated
2026-11-02
EUVDEUVD-2023-0588 No score

The jruby-openssl gem before 0.6 for JRuby mishandles SSL certificate validation.

Record
EUVD-2023-0588
Updated
2026-11-03
GitHub AdvisoriesGHSA-xgv7-pqqh-h2w9 7.5

jruby-openssl gem for JRuby fails to do proper certificate validation

A security problem involving peer certificate verification was found where failed verification silently did nothing, making affected applications vulnerable to attackers. Attackers could lead a client application to believe that a secure connection to a rogue SSL server is legitimate. Attackers could also penetrate client-validated SSL server applications with a dummy certificate.

Record
GHSA-xgv7-pqqh-h2w9
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVGHSA-xgv7-pqqh-h2w9 7.5

jruby-openssl gem for JRuby fails to do proper certificate validation

A security problem involving peer certificate verification was found where failed verification silently did nothing, making affected applications vulnerable to attackers. Attackers could lead a client application to believe that a secure connection to a rogue SSL server is legitimate. Attackers could also penetrate client-validated SSL server applications with a dummy certificate.

Record
GHSA-xgv7-pqqh-h2w9
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-295
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
jruby-openssl
RubyGems
before 0.6
0.6
jruby-openssl
RubyGems
before 0.6, plus listed versions
0.0.10.0.20.0.30.0.40.1
Show 10 moreShow less
0.1.10.20.2.10.2.20.2.30.30.40.50.5.10.5.2
0.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4123 is a high vulnerability (CVSS 7.5) in Jruby Jruby-openssl, published January 19, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.60%, the 48th percentile. Fixed in jruby-openssl 0.6.

References

MoveEnter Open