CVE-2023-0610
Improper Authorization in wallabag/wallabag
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.4
Improper Authorization in wallabag/wallabag
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.
- Record
CVE-2023-0610- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2023-0742
5.4
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.
- Record
EUVD-2023-0742- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mrqx-mjc4-vfh3
5.4
wallabag subject to Improper Authorization via annotations
Impact
The annotations feature lets users add annotations on highlighted parts of an entry.
The controller does not validate authorization on PUT and DELETE requests which lets a logged user modify or delete any annotation using their ID on their endpoints example.org/annotations/{id}.
These vulnerable requests also disclose highlighted parts of the entry to the attacker.
You should immediately patch your instance to version 2.5.3 or higher if you have more than one user and/or having open registration.
Resolution
A user check is now done in the vulnerable methods before applying change on an annotation.
The Annotation retrieval through a ParamConverter has also been replaced with a call to the AnnotationRepository in order to prevent any information disclosure through response discrepancy.
Workarounds
Credits
We would like to thank @bAuh0lz for reporting this issue through huntr.dev.
Reference: https://huntr.dev/bounties/8fdd9b31-d89b-4bbe-9557-20b960faf926/
- Record
GHSA-mrqx-mjc4-vfh3- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
NVD
4.3
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.
- Record
CVE-2023-0610- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSV
5.4
Improper Authorization in wallabag/wallabag
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.
- Record
CVE-2023-0610- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-mrqx-mjc4-vfh3
5.4
wallabag subject to Improper Authorization via annotations
Impact
The annotations feature lets users add annotations on highlighted parts of an entry.
The controller does not validate authorization on PUT and DELETE requests which lets a logged user modify or delete any annotation using their ID on their endpoints example.org/annotations/{id}.
These vulnerable requests also disclose highlighted parts of the entry to the attacker.
You should immediately patch your instance to version 2.5.3 or higher if you have more than one user and/or having open registration.
Resolution
A user check is now done in the vulnerable methods before applying change on an annotation.
The Annotation retrieval through a ParamConverter has also been replaced with a call to the AnnotationRepository in order to prevent any information disclosure through response discrepancy.
Workarounds
Credits
We would like to thank @bAuh0lz for reporting this issue through huntr.dev.
Reference: https://huntr.dev/bounties/8fdd9b31-d89b-4bbe-9557-20b960faf926/
- Record
GHSA-mrqx-mjc4-vfh3- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wallabag/wallabagPackagist |
2.0.0-beta.1 up to 2.5.3 | 2.5.3 |
wallabag/wallabagPackagist |
2.0.0-beta.1 up to 2.5.3, plus listed versions 2.0.02.0.0-beta.22.0.12.0.22.0.3 Show 33 moreShow less2.0.42.0.52.0.62.0.72.0.82.1.02.1.12.1.22.1.32.1.42.1.52.1.62.1.6.12.2.02.2.12.2.22.2.32.3.02.3.12.3.22.3.32.3.42.3.52.3.62.3.72.3.82.4.02.4.12.4.22.4.32.5.02.5.12.5.2 |
2.5.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-0610 is a medium vulnerability (CVSS 5.4) in Wallabag, published February 1, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in wallabag/wallabag 2.5.3.
References
huntr.dev/bounties/8fdd9b31-d89b-4bbe-9557-20b960faf926
github.com/wallabag/wallabag/commit/5ac6b6bff9e2e3a87fd88c2904ff3c6aac40722e
github.com/wallabag/wallabag/security/advisories/GHSA-mrqx-mjc4-vfh3
nvd.nist.gov/vuln/detail/CVE-2023-0610
github.com/advisories/GHSA-mrqx-mjc4-vfh3
github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0610.json
github.com/wallabag/wallabag