Every CVE Search/ Get API key

CVE-2020-36067

Improper Validation of Array Index in GJSON

7.5 HighFix available

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.44%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.5

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
CVE-2020-36067
CVSS 3.1
7.5 HighCVSS:3.1/AC:L/AV:N/A:H/C:N/I:N/PR:N/S:U/UI:N
Updated
2026-11-02
EUVDEUVD-2023-0752 7.5

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
EUVD-2023-0752
CVSS 3.1
7.5 HighCVSS:3.1/AC:L/AV:N/A:H/C:N/I:N/PR:N/S:U/UI:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-p64j-r5f4-pwwx 7.5

Improper Validation of Array Index in GJSON

GJSON < 1.6.6 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
GHSA-p64j-r5f4-pwwx
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-129
Updated
2026-11-02
NVD 7.5

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
CVE-2020-36067
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-129
Updated
2026-11-02
OSV 7.5

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
CVE-2020-36067
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-36067 7.5

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
DEBIAN-CVE-2020-36067
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-p64j-r5f4-pwwx 7.5

Improper Validation of Array Index in GJSON

GJSON < 1.6.6 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
GHSA-p64j-r5f4-pwwx
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-129
Updated
2026-11-02
OSVUBUNTU-CVE-2020-36067 7.5

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Record
UBUNTU-CVE-2020-36067
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGO-2021-0054 No score

Panic due to improper input validation in ForEach in github.com/tidwall/gjson

Due to improper bounds checking, maliciously crafted JSON objects can cause an out-of-bounds panic. If parsing user input, this may be used as a denial of service vector.

Record
GO-2021-0054
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/tidwall/gjson
Go
before 1.6.6
1.6.6
golang-github-tidwall-gjson
Debian:12
before 1.6.7-1
1.6.7-1
golang-github-tidwall-gjson
Debian:13
before 1.6.7-1
1.6.7-1
golang-github-tidwall-gjson
Debian:14
before 1.6.7-1
1.6.7-1
golang-github-tidwall-gjson
Ubuntu:20.04:LTS
All versions, plus listed versions
1.1.5-2
None known
golang-github-tidwall-gjson
Ubuntu:22.04:LTS
All versions, plus listed versions
1.6.7-1
None known
golang-github-tidwall-gjson
Ubuntu:24.04:LTS
All versions, plus listed versions
1.14.4-21.17.1-1
None known
golang-github-tidwall-gjson
Ubuntu:25.10
All versions, plus listed versions
1.17.1-1
None known
golang-github-tidwall-gjson
Ubuntu:26.10
All versions, plus listed versions
1.17.1-11.19.0-1
None known
golang-github-tidwall-gjson
Ubuntu:26.04:LTS
All versions, plus listed versions
1.17.1-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-36067 is a high vulnerability (CVSS 7.5) in Gjson Project Gjson, published January 5, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.44%, the 73rd percentile. Fixed in github.com/tidwall/gjson 1.6.6.

References

MoveEnter Open