Every CVE Search/ Get API key

CVE-2023-0870

Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)

8.1 HighFix available

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.30%Up 0.3 points since Mar 23, 2023
90%50%10%1%

What each source reports

CVE List Score used 8.1

Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Record
CVE-2023-0870
CVSS 3.1
8.1 HighCVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-352
Updated
2026-11-02
EUVDEUVD-2023-1053 8.1

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Record
EUVD-2023-1053
CVSS 3.1
8.1 HighCVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-jxr6-7qg5-8wv6 6.7

OpenNMS Meridian and Horizon vulnerable to Cross-Site Request Forgery

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Record
GHSA-jxr6-7qg5-8wv6
CVSS 3.1
6.7 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-352
Updated
2026-11-02
NVD 8.1

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Record
CVE-2023-0870
CVSS 3.1
8.1 HighCVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1
6.7 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-352
Updated
2026-11-02
OSV 8.1

Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Record
CVE-2023-0870
CVSS 3.1
8.1 HighCVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-jxr6-7qg5-8wv6 6.7

OpenNMS Meridian and Horizon vulnerable to Cross-Site Request Forgery

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Record
GHSA-jxr6-7qg5-8wv6
CVSS 3.1
6.7 MediumCVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.opennms:opennms-webapp
Maven
before 31.0.6
31.0.6

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-0870 is a high vulnerability (CVSS 8.1) in Opennms Horizon, published March 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.30%, the 23rd percentile. Fixed in org.opennms:opennms-webapp 31.0.6.

References

MoveEnter Open