CVE-2023-2106
Weak Password Requirements in janeczku/calibre-web
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List
9.8
Weak Password Requirements in janeczku/calibre-web
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
- Record
CVE-2023-2106- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-521, CWE-521
- Updated
- 2026-11-02
EUVDEUVD-2023-1352
9.8
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
- Record
EUVD-2023-1352- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mhmp-m6g7-7c24
7.3
Weak Password Requirements in calibreweb
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
- Record
GHSA-mhmp-m6g7-7c24- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-521
- Updated
- 2026-11-02
NVD
9.8
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
- Record
CVE-2023-2106- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-521
- Updated
- 2026-11-02
OSV
9.8
Weak Password Requirements in janeczku/calibre-web
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
- Record
CVE-2023-2106- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-521
- Updated
- 2026-11-02
OSVGHSA-mhmp-m6g7-7c24
7.3
Weak Password Requirements in calibreweb
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
- Record
GHSA-mhmp-m6g7-7c24- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-521
- Updated
- 2026-11-02
OSVPYSEC-2026-1233
7.3
Weak Password Requirements in calibreweb
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
- Record
PYSEC-2026-1233- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
calibrewebPyPI |
before 0.6.20 | 0.6.20 |
calibrewebPyPI |
before 0.6.20, plus listed versions 0.6.120.6.130.6.140.6.150.6.160.6.170.6.180.6.19 |
0.6.20 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-2106 is a high vulnerability (CVSS 7.3) in Janeczku Calibre-web, published April 15, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.75%, the 54th percentile. Fixed in calibreweb 0.6.20.
References
github.com/janeczku/calibre-web/commit/49e4f540c9b204c7e39b3c27ceadecd83ed60e7e
huntr.dev/bounties/c3d5c647-7557-40a9-aee4-24dc14882781
nvd.nist.gov/vuln/detail/CVE-2023-2106
github.com/advisories/GHSA-mhmp-m6g7-7c24
github.com/CVEProject/cvelistV5/tree/main/cves/2023/2xxx/CVE-2023-2106.json
github.com/janeczku/calibre-web
pypi.org/project/calibreweb