CVE-2022-46907
Apache JSPWiki: XSS Injection points in several plugins
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
- Record
CVE-2022-46907- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Apache JSPWiki: XSS Injection points in several plugins
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
- Record
CVE-2022-46907- Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2023-1614
0.0
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
- Record
EUVD-2023-1614- CVSS
- 0.0 None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qvq8-cw7f-m7m4
6.1
Apache JSPWiki vulnerable to cross-site scripting on several plugins
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
- Record
GHSA-qvq8-cw7f-m7m4- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-qvq8-cw7f-m7m4
6.1
Apache JSPWiki vulnerable to cross-site scripting on several plugins
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
- Record
GHSA-qvq8-cw7f-m7m4- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Apache JSPWiki: XSS Injection points in several plugins
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
- Record
CVE-2022-46907- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.jspwiki:jspwiki-mainMaven |
before 2.12.0 | 2.12.0 |
org.apache.jspwiki:jspwiki-warMaven |
before 2.12.0 | 2.12.0 |
org.apache.jspwiki:jspwiki-mainMaven |
before 2.12.0, plus listed versions 2.11.02.11.0.M12.11.0.M22.11.0.M32.11.0.M4 Show 7 moreShow less2.11.0.M52.11.0.M62.11.0.M72.11.0.M82.11.12.11.22.11.3 |
2.12.0 |
org.apache.jspwiki:jspwiki-warMaven |
before 2.12.0, plus listed versions 2.10.02.10.12.10.22.10.32.10.4 Show 13 moreShow less2.10.52.11.02.11.0.M12.11.0.M22.11.0.M32.11.0.M42.11.0.M52.11.0.M62.11.0.M72.11.0.M82.11.12.11.22.11.3 |
2.12.0 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | shoucheng3/apache__jspwiki_CVE-2022-46907_2-11-3 | 2025-08-17 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-46907 is a medium vulnerability (CVSS 6.1) in Apache Jspwiki, published May 25, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.16%, the 67th percentile. Fixed in org.apache.jspwiki:jspwiki-main 2.12.0.
References
lists.apache.org/thread/1m0mkq2nttx8tn94m11mytn4f0tv1504
openwall.com/lists/oss-security/2023/05/25/1
nvd.nist.gov/vuln/detail/CVE-2022-46907
github.com/apache/jspwiki/commit/0b9a0149032170063f22d65e335dfd317db815ea
github.com/apache/jspwiki/commit/46e1ef7a595ca5cabf5ef184139910413f2024fc
github.com/apache/jspwiki/commit/484c6a133e397693991b7c9a9b62ef3ca48ce707
Show 9 moreShow less
github.com/apache/jspwiki/commit/75019d337f1d0033b1f65428e75f43baeffd99dd
github.com/apache/jspwiki/commit/82be08904a6d8bd22fa2d4e5a7e85f43408724d3
github.com/apache/jspwiki/commit/9d6dbf911d52d724297e4e46c4b80649fb028ff9
github.com/apache/jspwiki/commit/df20770f251a8d7431047e556b144ef24ee6a3a7
github.com/apache/jspwiki/blob/37bf55373ed5a739a388a720163cf51d1104537f/ChangeLog.md?plain=1
jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-46907
github.com/advisories/GHSA-qvq8-cw7f-m7m4
github.com/CVEProject/cvelistV5/tree/main/cves/2022/46xxx/CVE-2022-46907.json
github.com/apache/jspwiki