CVE-2023-35840
elFinder vulnerable to path traversal in LocalVolumeDriver connector
_joinPath in elFinderVolumeLocalFileSystem.class.php in elFinder before 2.1.62 allows path traversal in the PHP LocalVolumeDriver connector.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
_joinPath in elFinderVolumeLocalFileSystem.class.php in elFinder before 2.1.62 allows path traversal in the PHP LocalVolumeDriver connector.
- Record
CVE-2023-35840- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List
6.5
_joinPath in elFinderVolumeLocalFileSystem.class.php in elFinder before 2.1.62 allows path traversal in the PHP LocalVolumeDriver connector.
- Record
CVE-2023-35840- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2023-1903
6.5
_joinPath in elFinderVolumeLocalFileSystem.class.php in elFinder before 2.1.62 allows path traversal in the PHP LocalVolumeDriver connector.
- Record
EUVD-2023-1903- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wm5g-p99q-66g4
7.5
elFinder vulnerable to path traversal in LocalVolumeDriver connector
Impact
Path Traversal vulnerability in PHP LocalVolumeDriver connector. This vulnerability can be exploited by allowing untrusted users to write to the local file system.
This issue was caused by incomplete validity checking of the supplied request parameters. That problem has been fixed in elFinder Version 2.1.62.
Patches
This vulnerability has been fixed in elFinder 2.1.62. Installation managers should update to the latest version as soon as possible.
Workarounds
If you cannot update for some reason, you must stop using it or prohibit writing to untrusted users.
- Record
GHSA-wm5g-p99q-66g4- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
6.5
_joinPath in elFinderVolumeLocalFileSystem.class.php in elFinder before 2.1.62 allows path traversal in the PHP LocalVolumeDriver connector.
- Record
CVE-2023-35840- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-wm5g-p99q-66g4
7.5
elFinder vulnerable to path traversal in LocalVolumeDriver connector
Impact
Path Traversal vulnerability in PHP LocalVolumeDriver connector. This vulnerability can be exploited by allowing untrusted users to write to the local file system.
This issue was caused by incomplete validity checking of the supplied request parameters. That problem has been fixed in elFinder Version 2.1.62.
Patches
This vulnerability has been fixed in elFinder 2.1.62. Installation managers should update to the latest version as soon as possible.
Workarounds
If you cannot update for some reason, you must stop using it or prohibit writing to untrusted users.
- Record
GHSA-wm5g-p99q-66g4- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
studio-42/elfinderPackagist |
before 2.1.62 | 2.1.62 |
studio-42/elfinderPackagist |
before 2.1.62, plus listed versions 2.0.32.0.42.0.52.0.62.0.7 Show 45 moreShow less2.0.82.0.92.1.02.1.12.1.102.1.112.1.122.1.132.1.142.1.152.1.162.1.172.1.182.1.192.1.22.1.202.1.212.1.222.1.232.1.242.1.252.1.262.1.272.1.282.1.292.1.32.1.302.1.312.1.322.1.332.1.342.1.352.1.362.1.372.1.382.1.392.1.42.1.402.1.412.1.422.1.432.1.442.1.452.1.462.1.47 |
2.1.62 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | afine-com/CVE-2023-35840 | 2023-06-22 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-35840 is a medium vulnerability (CVSS 6.5) in Std42 Elfinder, published June 14, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.94%, the 80th percentile. Fixed in studio-42/elfinder 2.1.62.
References
github.com/Studio-42/elFinder/security/advisories/GHSA-wm5g-p99q-66g4
github.com/Studio-42/elFinder/commit/bb9aaa7b096a1b83f2f85657c43f12131ece2891
github.com/sectroyer/CVEs/tree/main/CVE-2023-35840
github.com/afine-com/CVE-2023-35840
github.com/advisories/GHSA-wm5g-p99q-66g4
github.com/CVEProject/cvelistV5/tree/main/cves/2023/35xxx/CVE-2023-35840.json
nvd.nist.gov/vuln/detail/CVE-2023-35840
github.com/Studio-42/elFinder
Left out here: 19 versions. The JSON record has them.