CVE-2023-32693
Decidim Cross-site Scripting vulnerability in the external link redirections
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.1
Decidim Cross-site Scripting vulnerability in the external link redirections
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.
- Record
CVE-2023-32693- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2023-1946
8.1
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.
- Record
EUVD-2023-1946- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-469h-mqg8-535r
6.1
Decidim Cross-site Scripting vulnerability in the external link redirections
Impact
The external link feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing.
Patches
- Record
GHSA-469h-mqg8-535r- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
8.1
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.
- Record
CVE-2023-32693- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
8.1
Decidim Cross-site Scripting vulnerability in the external link redirections
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.
- Record
CVE-2023-32693- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-469h-mqg8-535r
6.1
Decidim Cross-site Scripting vulnerability in the external link redirections
Impact
The external link feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing.
Patches
- Record
GHSA-469h-mqg8-535r- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
decidim-coreRubyGems |
0.27.0 up to 0.27.3 | 0.27.3 |
decidimRubyGems |
0.27.0 up to 0.27.3 | 0.27.3 |
decidimRubyGems |
0.25.0 up to 0.26.7 | 0.26.7 |
decidim-coreRubyGems |
0.25.0 up to 0.26.7 | 0.26.7 |
decidimRubyGems |
0.25.0 up to 0.26.7, plus listed versions 0.25.10.25.20.26.00.26.0.rc20.26.1 Show 4 moreShow less0.26.20.26.30.26.40.26.5 |
0.26.7 |
decidim-coreRubyGems |
0.27.0 up to 0.27.3, plus listed versions 0.27.10.27.2 |
0.27.3 |
decidim-coreRubyGems |
0.25.0 up to 0.26.7, plus listed versions 0.25.10.25.20.26.00.26.0.rc10.26.0.rc2 Show 5 moreShow less0.26.10.26.20.26.30.26.40.26.5 |
0.26.7 |
decidimRubyGems |
0.27.0 up to 0.27.3, plus listed versions 0.27.10.27.2 |
0.27.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-32693 is a high vulnerability (CVSS 8.1) in Decidim, published July 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.82%, the 57th percentile. Fixed in decidim-core 0.27.3.
References
github.com/decidim/decidim/security/advisories/GHSA-469h-mqg8-535r
github.com/decidim/decidim/releases/tag/v0.26.7
github.com/decidim/decidim/releases/tag/v0.27.3
nvd.nist.gov/vuln/detail/CVE-2023-32693
github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2023-32693.yml
github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2023-32693.yml
github.com/advisories/GHSA-469h-mqg8-535r
github.com/CVEProject/cvelistV5/tree/main/cves/2023/32xxx/CVE-2023-32693.json
github.com/decidim/decidim