Every CVE Search/ Get API key

CVE-2023-32200

Apache Jena: Exposure of execution in script engine expressions.

8.8 HighFix available

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.47%Up 1.4 points since Jul 12, 2023
90%50%10%1%

What each source reports

NVD Score used 8.8

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Record
CVE-2023-32200
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-917
Updated
2026-11-02
CVE List 8.8

Apache Jena: Exposure of execution in script engine expressions.

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Record
CVE-2023-32200
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-917
Updated
2026-11-02
EUVDEUVD-2023-2087 8.8

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Record
EUVD-2023-2087
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-j927-w6g7-7c7w 8.8

Apache Jena Expression Language Injection vulnerability

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena from 3.7.0 through 4.8.0.

Record
GHSA-j927-w6g7-7c7w
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-917
Updated
2026-11-02
OSV 8.8

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Record
CVE-2023-32200
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-32200 8.8

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Record
DEBIAN-CVE-2023-32200
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-j927-w6g7-7c7w 8.8

Apache Jena Expression Language Injection vulnerability

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena from 3.7.0 through 4.8.0.

Record
GHSA-j927-w6g7-7c7w
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-917
Updated
2026-11-02
OSVUBUNTU-CVE-2023-32200 8.8

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Record
UBUNTU-CVE-2023-32200
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.jena:jena
Maven
3.7.0 up to 4.9.0
4.9.0
apache-jena
Debian:12
All versions, plus listed versions
4.5.0-24.9.0-1
None known
apache-jena
Debian:13
before 4.9.0-1
4.9.0-1
apache-jena
Debian:14
before 4.9.0-1
4.9.0-1
org.apache.jena:jena
Maven
3.7.0 up to 4.9.0, plus listed versions
3.10.03.11.03.12.03.13.03.13.1
Show 18 moreShow less
3.14.03.15.03.16.03.17.03.8.03.9.04.0.04.1.04.2.04.3.04.3.14.3.24.4.04.5.04.6.04.6.14.7.04.8.0
4.9.0
apache-jena
Ubuntu:22.04:LTS
All versions, plus listed versions
3.17.0-13.17.0-23.17.0-3
None known
apache-jena
Ubuntu:24.04:LTS
All versions, plus listed versions
4.5.0-24.9.0-1
None known
apache-jena
Ubuntu:25.10
All versions, plus listed versions
4.9.0-1
None known
apache-jena
Ubuntu:26.10
All versions, plus listed versions
4.9.0-1build1
None known
apache-jena
Ubuntu:26.04:LTS
All versions, plus listed versions
4.9.0-14.9.0-1build1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-32200 is a high vulnerability (CVSS 8.8) in Apache Jena, published July 12, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.47%, the 73rd percentile. Fixed in org.apache.jena:jena 4.9.0.

References

Show 4 moreShow less
MoveEnter Open