Every CVE Search/ Get API key

CVE-2023-26364

Denial of Service of regular expression in package @adobe/css-tools

5.3 MediumFix available

@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

1.15%Up 1.1 points since Nov 18, 2023
90%50%10%1%

What each source reports

CVE List Score used 5.3

Denial of Service of regular expression in package @adobe/css-tools

@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.

Record
CVE-2023-26364
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2023-2304 5.3

@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.

Record
EUVD-2023-2304
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-hpx4-r86g-5jrg 5.0

@adobe/css-tools Regular Expression Denial of Service (ReDOS) while Parsing CSS

Impact

@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.

Patches

The issue has been resolved in 4.3.1.

Workarounds

None

References

N/A

Record
GHSA-hpx4-r86g-5jrg
CVSS 3.1
5.0 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
Weakness
CWE-20, CWE-1333
Updated
2026-11-02
NVD 5.3

@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.

Record
CVE-2023-26364
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-hpx4-r86g-5jrg 5.0

@adobe/css-tools Regular Expression Denial of Service (ReDOS) while Parsing CSS

Impact

@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.

Patches

The issue has been resolved in 4.3.1.

Workarounds

None

References

N/A

Record
GHSA-hpx4-r86g-5jrg
CVSS 3.1
5.0 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
Weakness
CWE-1333, CWE-20
Updated
2026-11-02
OSVSUSE-SU-2024:1415-1 No score

Security update for cockpit-wicked

This update for cockpit-wicked fixes the following issues:

  • CVE-2023-26364: Fixed denial of service due to improper input validation during CSS parsing (bsc#1217325)

Other fixes:

  • Update to version 5~git8.c06c55b.
Record
SUSE-SU-2024:1415-1
Updated
2026-11-02
OSVSUSE-SU-2024:1415-2 No score

Security update for cockpit-wicked

This update for cockpit-wicked fixes the following issues:

  • CVE-2023-26364: Fixed denial of service due to improper input validation during CSS parsing (bsc#1217325)

Other fixes:

  • Update to version 5~git8.c06c55b.
Record
SUSE-SU-2024:1415-2
Updated
2026-11-02
OSVSUSE-SU-2024:1416-1 No score

Security update for cockpit-wicked

This update for cockpit-wicked fixes the following issues:

  • CVE-2023-26364: Fixed denial of service due to improper input validation during CSS parsing (bsc#1217325)

Other fixes:

  • Upgrade to version 4.5
Record
SUSE-SU-2024:1416-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
@adobe/css-tools
npm
before 4.3.1
4.3.1
cockpit-wicked
SUSE:Linux Enterprise Micro 5.5
before 5~git8.c06c55b-150500.3.3.1
5~git8.c06c55b-150500.3.3.1
cockpit-wicked
SUSE:Linux Enterprise Micro 5.4
before 4.5-150400.3.3.1
4.5-150400.3.3.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-26364 is a medium vulnerability (CVSS 5.3) in Adobe Css-tools, published August 29, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. Fixed in @adobe/css-tools 4.3.1.

References

Show 4 moreShow less
MoveEnter Open